Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Continued from: http://serverfault.com/questions/172349/wbadmin-system-state-backup-fails

When I put the following a bat file and run it as scheduled task, I see that the webadmin.exe process starts but it never seems to create backup:

wbadmin start systemstatebackup -backuptarget:\\server\foo -quiet

This seems to run fine when I run the bat file directly. I have the scheduled task configured to run with the "highest privileges". The share doesn't use windows authentication but it is a mapped network drive.

share|improve this question
    
Also I see some posts on the internet about -user parameter which seems to be absent from my version ... –  Kyle Brandt Aug 19 '10 at 20:41
    
Throwing in a net use command to bat file to see if that helps for some reason ... –  Kyle Brandt Aug 19 '10 at 20:49

2 Answers 2

I've had similar problems with NTBackup in the past when it was scheduled to run under the NT AUTHORITY\SYSTEM user because it doesn't have any network permissions whatsoever, so just hung indefinitely.

To fix the problem, I had to run the scheduled task under my own user account.

share|improve this answer
up vote 0 down vote accepted

It seems adding the net use command before fixed it, so it must have something to do with creating a new session for the scheduled task. The command was something like:

net use \\backupServer\backups /u:backupUser shhhSecret
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.