Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been trying to access my shared folders from the command line in my virtual machine with no luck. I've stumbled across a couple of references to using net use to establish a virtual drive, but i can't get this to work correctly:

net use z: \\.host\y (where y is my shared folder)
net use z: \\.host\shared folders\y

Neither of these works. Any pointers?

share|improve this question

In place of ".host" have you tried its IP address instead? Also... Any chance that the VM was hosted on a different host at any point?

share|improve this answer
i'm not sure how to find out the ip address of the host. it's physically on the same machine. would i just use the default gateway address? if so, that doesn't work. no, the vm was never hosted anywhere else. – jim Aug 21 '10 at 23:18
Which type of networking is set up on the guest - bridged or NAT? If it is setup for NAT, then the host IP in that arrangement is the NAT default gateway/DHCP server. – user48838 Aug 22 '10 at 6:48
yes, it's setup as nat, the default gateway address produced the same error: 67. – jim Aug 22 '10 at 14:46
Is the "host" machine that you are trying to reach actually another "guest" virtual machine which is also on a NAT setup? If so, you will need to consider changing it over to Bridged or creating and "internal" network (via Internal virtual NICs) between the virtual machines. – user48838 Aug 22 '10 at 19:08
no, the host is the physical machine the vm is running on. – jim Aug 22 '10 at 20:03

are you going to do it only once ? If yes, use scp to finish your work quickly :> Are you sure that the folders are shared ? Were you able to access them from another machine ?

share|improve this answer
no, i'm going to be doing it on regular intervals. this is for a batch file for backing up files to another drive in shared folders which is on the same machine which is hosting the vm. – jim Aug 21 '10 at 22:50
ok then. but the question remains :> were you able to access the shared folder from another machine ? That's a question to determine if the problem is located in VM's configuration or in the connection between VM and host machine. – Nikolaidis Fotis Aug 21 '10 at 23:35
i've never tried accessing the share from another machine. the share is enabled from directly within vmware workstation solely for that particular machine. – jim Aug 22 '10 at 14:47
up vote 0 down vote accepted

ok, after much pounding my head, i found the answer. it actually had nothing to do with the vm, the network, or permissioning. turns out it was a short 8.3 format name problem. as can be seen in my question i was calling 'shared folders' without quotes and without short syntax. to correctly call shared folders from within a vm (or otherwise) from the cmd line, you must wrap up the directory call in quotes as below:

dir "\.host\shared folders"


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.