Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My vhost config:

<VirtualHost *:443>
    ServerName test1.site.com

    DocumentRoot /var/www/test1.site.com

    <Location /svn>

            DAV svn
            SVNListParentPath on
            SVNParentPath /opt/svn

   </Location>

    SSLEngine on
    SSLCertificateFile    /etc/apache2/ssl/server.pem
    SSLCertificateKeyFile /etc/apache2/ssl/server.key

I've created repos with command:

svnadmin create /opt/svn/reponame

When I'm pointing my browser to https://site.com/svn it shows all my project and files, its OK.

Error when checkouting:

$ svn checkout  https://test1.site.com/svn/ ./
svn: Repository moved temporarily to 'https://test1.site.com/svn/'; please relocate
$ svn checkout  https://test1.site.com/svn/projectname ./
svn: Repository moved temporarily to 'https://test1.site.com/svn/projectname/'; please relocate

$ tail -2 /var/log/apache2/other_vhosts_access.log 
test1.site.com:443 93.12.33.100 - - "OPTIONS /svn HTTP/1.1" 302 274 "-" "SVN/1.6.6 (r40053) neon/0.29.0"
test1.site.com:443 93.12.33.100 - - "OPTIONS /svn/projectname HTTP/1.1" 302 277 "-" "SVN/1.6.6 (r40053) neon/0.29.0"

There is no config options in /etc/apache2/mods_enabled/dav_svn.conf, there is no other VirtualHosts in Apache2.

I've spent about 10 hours be there is no result :( I've tried creating new repos, setting Error 404 default, same shit!

share|improve this question
    
do you have a .htaccess in your document root or any global rewrite or redirect rules in your apache config? –  Marcel G Oct 31 '10 at 9:44
add comment

1 Answer

How about svn checkout https://test1.site.com/svn/projectname/ ?

The first error you get is normal - Since you are using the SVNListParentPath directive, accessing the /svn URI will give you a list of repositories that you can browse. However, you need to provide a URL to an actual repository to checkout.

The second error is weird - it should just do the right thing, but strictly speaking the URL should end with a /.

What version of apache and subversion are you using ?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.