Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

It seems I cannot install the current version of OpenVPN (2.1.2) because the TAP driver is not signed and therefore windows 7 x64 refuses to install it.
It shows up in the device manager, but with a yellow exclamation mark.
It's a fresh system, and OpenVPN was never installed before.

When I start the OpenVPN client it seems to connect fine, but then it stops with

CreateFile failed on TAP device: ...
All TAP-Win32 adapters on this system are currently in use.

How can I install the unsigned drivers, or are there signed drivers available somewhere ?

share|improve this question
    
You can try this solution. Worked for me, but it's kind of ugly. – coredump Aug 21 '10 at 12:55
    
Check if your TAP-Win32 Adapter is enabled from control panel - network center... – Rasta yesterday
up vote 5 down vote accepted

To install, the application has to be run in Vista Compatibility mode.

Download OpenVPN 2.1 and then :

1) After downloading, right-click on the file and select 'properties' then 'compatibility mode'
2) Select 'Windows Vista (Service Pack 1)'
3) For privilege level, select 'Run this program as administrator'
4) Click 'Apply' and then 'OK' to exit
5) Double-click on the installation file install. Agree to any questions that pop up. Click next where prompted.
Note: The installation of the TAP adapter can sometimes take up to a minute. Do not exit the installer while the TAP adapter is being processed.

Once the program is installed you need to mark OpenVPN-GUI in compatibility mode with Vista(SP1) and then mark checkbox "Run As an Administrator".

share|improve this answer
    
his unfortunately doesn't work. I removed the device along with its drivers from the device manager and uninstalled OpenVPN. During the re-install when asked to install the unsigned driver I clicked yes, but the end result was the exact same. – Darcara Aug 21 '10 at 13:27
1  
Just tried with an older version (2.1 RC19) and it worked... – Darcara Aug 21 '10 at 13:34

protected by Sven yesterday

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.