Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a ton of issues when my ASP.NET sites are using version 2. For example, all my SVC and ASPX files return "file not found". Also when I use IISMgr and navigate to:

ServerName
..... Web Service Extensions

I notice that no ASP.NET v2 is present. I tried aspnet_regiis but no luck. Any ideas?

alt text

UPDATE

Running aspnet_regiis.exe – i seemed to now have worked. But I'm still having issues with WCF. I just tried reinstalling WCF using ServiceModelReg -i and I get this in the event log

alt text

Also, this is what ServiceModelReg -ls looks like (note no Web Host Script Mappings exist)

alt text

share|improve this question

1 Answer 1

up vote 2 down vote accepted

No, this is not normal; you should have three ASP.NET externsions there: 1.1, 2.0 and 4.0.

Which aspet_regiis did you try? The 2.0 one or the 4.0 one?

Is this a x86 or x64 server?

For x86, run C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -ir.

For x64, run C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -ir.

share|improve this answer
    
AWESOME, That worked! It's back. I just ran ServiceModelReg to reinstall WCF, and it says I have no Web Host Script Mappings. Does that make sense? –  makerofthings7 Aug 21 '10 at 18:54
    
The command I used was: C:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication Foundation>ServiceModelReg.exe -lv –  makerofthings7 Aug 21 '10 at 21:03
    
Is there a reason you didn't mark this as the answer? –  GregD Aug 21 '10 at 22:05
    
WCF is still broken, but I can create a new one for that... –  makerofthings7 Aug 21 '10 at 22:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.