Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I connect to my ec2 instance using ssh so I don't have to login each time.

I just installed vsftpd on the ubuntu server, but when I connect it obviously asks for my username and password.

Since I connect using the ubuntu user that my AMI comes with, I don't even know the root password.

Is there a way I can login via ftp using SSH?

Or do I just create a user on the system for ftp purposes?

I've locked ftp to my IP address, and I will shutdown the ftp service once I'm done as I dont need it running 99.99999% of the time.

share|improve this question

If you're not comfortable with command line scp then you could use a client like filezilla configured in it's server manager dialogue to connect to Server Type: SFTP - SSH File Transfer Protocol

You may have to enable the sftp server on your AMI. Check that the line

Subsystem sftp /usr/lib/openssh/sftp-server

is not commented out with a # in /etc/ssh/sshd_config

share|improve this answer

No. SSH and FTP are different protocols.

If you have SSH running then just use scp or rsync to copy files over, no FTP needed.

share|improve this answer

First you will have to set up password for your ubuntu server ec2 instance. If your username is 'ubuntu' you can create a password for it using

sudo passwd ubuntu

You can then try connecting to EC2 instance using FTP with the username and password.

If i'm right, you'll have to set filezilla or your FTP client to active mode ( from preferences ) to connect to EC2 instance.

If you havent configured your FTP server in EC2 Ubuntu instance, here is a guide to do that

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.