Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm looking into the possibility of using Wake On Lan for a machine used in a test lab to run VMs. It doesn't really need to be on all the time, so it would be nice to be able to power it down when it's not being used to save electricity.

Looking through Dell's WoL support documentation, the NIC (Dual Embedded Broadcom® NetXtreme II 5708 Gigabit Ethernet NIC) should supposedly support WoL. The doc is a little old, though, and doesn't discuss Server 2k8, much less 2k8 R2.

Nevertheless, one of the steps in the Server 2k3 configuration details specifies that hibernation support should be enabled; however, when going into the power options for my server, there are no hibernation configuration options in the gui.

I should note that my understanding of WoL is fairly weak. Do systems monitoring the network for magic packets need to be explicitly hibernated, and not shut off as normal? I wouldn't think that the way the OS shut down the system would affect the motherboard's ability to run power to the NIC, but then again this is not my area of expertise.

I will assume for now that hibernation is specifically required. Looking around some more, there seems to be indication that hibernation is not supported for systems that run the Hyper-V role--something to do with the Hypervisor. If this is true, it means that my desired configuration would be impossible. Can anyone provide confirmation or additional detail about this?

share|improve this question
    
To turn on hibernation in W2K8 and W2K8R2 run the following from a command prompt (as administrator): powercfg.exe -h on –  joeqwerty Aug 22 '10 at 21:28
    
Powercfg can't turn on hibernation with the Hyper-V roll installed. Hyper-V disables hibernation, as the hypevisor is incompatible with it. Even if you did enable hibernation, it wouldn't help much with boot time. The management OS (which is what you would be hibernating) isn't particularly stateful, so it boots about as a fast as it could resume from hibernation. –  Jake Oshins Aug 23 '10 at 16:44
    
See Helvick's answer. (In my opinion, his is the one you should "accept.") You should view this problem as one of "remote power on" not "remote resume from hibernation." –  Jake Oshins Aug 23 '10 at 16:45
add comment

2 Answers

up vote 2 down vote accepted

I don't know this Dell system, but in all systems I know, you need to turn on WOL in the BIOS. Hibernating Windows would then help with the boot time, but is not required per se.

share|improve this answer
    
Well, this is embarrassing. I looked in the BIOS before writing this question and didn't find anything, however the documentation I linked above seems to suggest that it isn't necessary under Server 2000 and 2003 (and assumedly 2008). Furthermore, when I had looked in the NIC's own configuration during boot, I had assumed "Pre-boot Wake on Lan" was referring to PXE since the "boot configuration" setting was set to "Pre-Boot Configuration Environment." I took a leap of faith and enabled that setting, and it works now. Thanks! –  bwerks Aug 23 '10 at 0:25
add comment

I don't have any issues with using WoL on a Dell R300 running VMware ESXi and that definitely doesn't support hibernation. Enable WoL in the BIOS, power it off and give it a go.

If WoL proves awkward the 2900 also supports remote power management via IPMI - if you download the Dell IPMI command line tools and enable the BMC you can check the power state of the server and remotely power it on (and power it off) with ipmish :

ipmish -ip 192.168.1.10 -u root -p calvin power on 

Obviously you will also want to change from the default username\password used in the example and you have to give it its own ip-address. Pretty much all Dell (and other vendor) servers that aren't really ancient support out of band IPMI in this way even if you haven't stumped up for a full blown OOB DRAC\iLO remote management card.

share|improve this answer
    
Great information here, thanks! –  bwerks Aug 23 '10 at 0:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.