Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install bugzilla and I keep getting the error that the required module Email::MIME is not found.

However, when I run the install command I get:

/usr/bin/perl install-module.pl Email::MIME
Checking for CPAN (v1.81) ok: found v1.93
Checking for YAML (any) ok: found v0.71
CPAN: Storable loaded ok (v2.21)
Going to read /home/thethewr/.cpan/Metadata
Database was generated on Mon, 23 Aug 2010 00:30:03 GMT
Installing Email::MIME version 1.903...
Email::MIME is up to date (1.903).

Yet bugzilla says

Checking for          Email-MIME (v1.861)   not found
share|improve this question
    
I'm seeing the same problem. Bugzilla 3.6.2 does not recognize Email::MIME v1.903. I'm trying to upgrade from Bugzilla 3.4 to 3.6.2 and this is blocking me. Has someone found a workaround for this? –  xdog Aug 25 '10 at 13:06
    
It was fixed yesterday (Aug 30). rt.cpan.org/Public/Bug/Display.html?id=60765 Fix showed up in 1.891 search.cpan.org/~rjbs/Email-Address-1.891 –  xdog Aug 31 '10 at 14:23

6 Answers 6

Email::MIME uses Email::Address.

A recent update to Email::Address accidently included a feature which requires Perl 5.10 (Perl Bug 60765).

You can check if this issue is impacting you by running the following from the Bugzilla directory:

perl -Mlib=lib -MEmail::MIME -e1

If you see a Sequence (?|...) not recognized in regex error, then that's what is going on with your installation.

An updated Email::Address is due "in a few days".

share|improve this answer
    
A version of Email-Address which fixes this was released to CPAN on the 30th of August. –  glob Sep 6 '10 at 1:07
    
so here it is two years later and I've found the same bug =/ –  ZeroDivide Jul 18 '12 at 14:40

It appears as if Bugzilla is perhaps looking for a specific version of Email::MIME: v1.861, and you have 1.903 installed.

share|improve this answer
    
That's sorta what I was thinking. –  BandonRandon Aug 23 '10 at 3:01
    
no, bugzilla will work with more recent versions of modules –  glob Aug 23 '10 at 4:56

Like glob said, it is from a bug in Email::Address. A work around is to wipe your bugzilla lib folder, and then use the "manual installation instructions" in the docs to install the previous release of Email::Address

http://search.cpan.org/~rjbs/Email-Address-1.889/

Then run 'perl install-module.pl Email::MIME', then checksetup.pl should pick it up. I got the tip from #mozwebtools on irc.mozilla.org.

share|improve this answer

I deleted the bugzilla/lib/Email directory and that fixed it for me.

share|improve this answer

Ha, looks like it was fixed yesterday, Email-Address-1.891 was posted aug 30th.

share|improve this answer

dgennuso,

What I did (following xp314a's tip) was download the older version of Email::Address (Email-Address-1.889.tar.gz)

Then from the shell:

cd /tmp
tar /directory-where-you-downloaded-it/Email-Address-1.889.tar.gz
cd Email-Address-1.889
perl Makefile.PL
make
make test
make install

At this point it should create an Email directory under /tmp/Email-Address-1.889/lib. Move that to your bugzilla/lib directory.

After that, I was able to install the remaining modules.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.