Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using putty to make ssh connection with my server.

I use up and down arrow button to go through history commands.

but now when i press backspace instead of deleting the character , some weired chacater appear like

service mysql stop


 service mysql stop^?^?^?

why is that , everything was ok before

share|improve this question
add comment

4 Answers

up vote 0 down vote accepted

You can reset the key while logged in by entering stty erase <then hit the backspace> That will set the backspace to whatever character you are sending as backspace for that terminal session. tylerl's response is a better long-term fix.

share|improve this answer
add comment

And just something to have in mind. Generally, if backspace doesn't work, try with ctrl + H

share|improve this answer
    
thanks buddy , that was very handy –  John Aug 24 '10 at 6:41
add comment

If the backspace was working okay initially and no longer is then try using the "reset" command. Look around putty's options menu for a "send hard reset" option as well. If it was never working then try what tylerl suggested.

share|improve this answer
add comment

In the putty options under Terminal >> Keyboard there's an option to change your backspace emulation. Change it and see if it makes things better.

Alternately (or additionally) mess around with the checkboxes under Terminal >> Features to see if one of those (such as "Disable destructive backspace...") fixes your problem.

There's a complex interaction between terminals and hosts using a set of conflicting standards which makes getting the right match a bit of a trial-and-error exercise.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.