Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running ESXi 4.1 on a Dell T110 Server
I connect to ESXi using vSphere
vSphere is running inside a Windows 7 VM
The Windows 7 VM is running in VMware Fusion on my Mac OS X system

When I'm in vSphere and I've selected a VM and I click the console tab on some systems the VM console won't release me when I press the control + command keys.

pfSense (FreeBSD) and Ubuntu Server behave like this. I can't exit their console screen. I have to shut down these VM's to be released from their VM console access.

Windows, Ubuntu Desktop, etc. all behave like I'd expect; When I press the control + command keys I'm released from the VM console and I'm able to navigate in vSphere.

Does anyone know what might be causing this or a way around this?

Thanks in advance.

share|improve this question

4 Answers 4

up vote 8 down vote accepted

The key combination Control + Alt solves this problem

share|improve this answer
3  
On mac (with Windows Parallel desktop) do Control + Alt + ESC. –  Laguiz Mar 27 at 15:34

Control + Option on the Mac Keyboard should do this for you (Option on my keyboard has an alt on it too).

I also ran into a similar problem in a Windows XP VM that had once connected to a VMware Server 1 Console, and had the key sequence changed to Shift + Alt in the configuration. That was a real pain to figure out, because the ESX console insisted that the exit sequence was Control + Alt.

share|improve this answer

I've run into something like this inside a Windows XP VM running in VirtualBox on Ubuntu.

The problem can be traced back to the fact that either the virtual host or the system running the virtual host usurp one or more of the key combinations used by this "VM" (console) running in a virtualized system.

In Ubuntu, I had the "locate mouse pointer" activated - which uses the Control key (by itself) to locate the pointer. This meant that "control-alt" was usurped by the operating system for the mouse locator function.

Things improved when I shut that off. It also worked better when I used "alt-control" (ALT followed by CONTROL - pressed and held) instead of the reverse.

Look out for keys like this in the operating system and in the virtual machine host; they will supersede anything in the virtual machine.

share|improve this answer

I highly recommend installing VMWare Tools on the guest systems as this allows for fluid movement of the mouse between the guest machine's console and your system.

In Linux you can use the this method or follow this tutorial to install VMWare tools. VMWare tools also improves performance of the guest's virtual hardware so it is recommended to install this on all guest systems.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.