Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

A user is trying to send a large email (over 10MB) but Exchange says they cannot do this as the limit (10MB) is being reached. How can I turn off the limit for this user please?

share|improve this question

migrated from superuser.com Aug 23 '10 at 16:50

This question came from our site for computer enthusiasts and power users.

    
Silly question perhaps but in light of the investigations below, I've got to ask if you're 100% sure it's the exchange server itself and not another system further up the path that is rejecting the email. My servers would certainly bounce a 10mb email straight back at you with no further discussion. –  RobM Aug 23 '10 at 21:22

2 Answers 2

Which version of Exchange?

In any version, you can set per-user quota limits which override the default global limits and the default mailbox database's limits.

If the message is addressed to an external user, you'll also need to check the limits on outbound messages.

Exchange 2003:
http://www.msexchange.org/tutorials/Set-Size-Limits-Messages.html

Exchange 2007:
http://www.msexchange.org/articles-tutorials/exchange-server-2007/management-administration/exchange-2007-message-size-limits.html

share|improve this answer
    
I'm running SBS 2008 and Exchange 2007. I read that link and tried the Get-Mailbox cmdlet for the user in-question and it said MaxSend is 50MB, MaxReceive is unlimited. But they still cannot send the email. Does this mean I have to remove the restriction from the server to get it to work –  Reado Aug 23 '10 at 17:25
    
Yes, if you have a restriction on the send connector for Internet messages, it will apply globally. The user will be able to send large messages to other internal users, but not to external addresses. –  Massimo Aug 23 '10 at 17:36
    
So there's no way to remove the restriction on a per-user basis for external messages? –  Reado Aug 23 '10 at 17:50
    
I've just removed the limit from the send connector. Tried to re-send my 20MB email to an external contact, and it bounced back again, from my server saying I had exceeded the send limit. There is no limit. Is this a bug in Exchange? –  Reado Aug 23 '10 at 18:04
    
Something's not right here... Just ran "Set-Transportconfig -maxsendsize 50MB" and tried again. Exchange still says a 20MB email is too big! What's causing this? –  Reado Aug 23 '10 at 18:12

The message size limits are set system-wide on the Send and Receive Connectors. It can not be set per-user.

share|improve this answer
    
The sbs-2008 may have been a mistag, if your answer was specific to that version. –  Kara Marfia Aug 23 '10 at 17:03
    
The limits on connectors only apply to message going through them, which is not always the case. A limit on a send connector will not apply to a message sent between internal users. –  Massimo Aug 23 '10 at 17:04
    
Sorry yes this is related to SBS 2008. This problem is with emails sent to external users. In Exchange there is an option to set the send/receive limit, and although I've changed it to 51200KB (50MB) it still doesn't allow the user to send the email. –  Reado Aug 23 '10 at 17:08
    
@reado, read my link on Exchange 2007. There are various limits that can influence a user's maximum allowed message size, and if they conflict, the lowest one applies. –  Massimo Aug 23 '10 at 17:13
    
@Kara My apologies it is indeed related to SBS2008. I fixed the post before migrating it, and the revision history did not migrate along. –  Diago Aug 23 '10 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.