Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have reviewed both related posts on this site:

How do I disable SSL 2.0 support on IIS?

How to disable SSL 2.0 on IIS 7.5?

The issue I am having is that I have implemented the registry change, rescanned my websites, and I am still being told that IIS 6 is allowing SSL 2.0 connections.

Here's the verbage from the scanning site:

Synopsis : The remote service encrypts traffic using a protocol with known weaknesses. Description : The remote service accepts connections encrypted using SSL 2.0, which reportedly suffers from several cryptographic flaws and has been deprecated for several years. An attacker may be able to exploit these issues to conduct man-in-the-middle attacks or decrypt communications between the affected service and clients.

QUESTIONS:

  • How do I test this myself so I can continue to troubleshoot the issue?
  • Is there a tool out there that I can use to test?
  • Would I need to disable other connection methods? [PCT 1.0 / TLS 1.0]

Thanks

share|improve this question

1 Answer 1

up vote 4 down vote accepted

You will need to disable PCT 1.0 as well as SSLv2, as it is no longer used. If you follow the MS KB, then you should be fine. You can use ssllabs.com to test your server if it is reachable over the Internet. Also you could use the G-SEC tool for configuring SSL/TLS on Windows.

share|improve this answer
    
I'll disable PCT 1.0, reboot, rescan, and see what happens... –  I.T. Support Aug 23 '10 at 20:50
    
I used GSEC, and peered into the registry to see what keys were being added. Turns out the keys GSEC entered are nothing like what the KB article suggests. I won't know if GSEC's reg entries worked unti lafter hours (when I reboot it), but it's worth mentioning. –  I.T. Support Aug 23 '10 at 21:08
    
Can you share what reg keys GSEC modified and what you expected to be modified? –  Nasko Aug 23 '10 at 21:10
    
According to MS KB, you add a DWORD [00 00 00 00] to the "Server" sub key underneath the corresponding protocol. GSEC doesn't add this key, but instead adds two other DWORDS: DisabledByDefault [1] & Enabled [0]. I'll post again once I reboot and evaluate –  I.T. Support Aug 23 '10 at 21:56
    
The KB does say that you need to add DWORD named Enabled and set it to 0. The DisabledByDefault will have no effect once Enabled is set to 0, it only governs whether the protocol is present by default when the protocol is enabled. –  Nasko Aug 23 '10 at 21:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.