Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've tried to install mod_passenger on a 64 bit CentOS5.3 machine and the module compiles into a 32 bit .so file. Followed standard recipe: gem install passenger; passenger-install-apache2-module.

  • apache 2.2.3
  • Rails 2.3.5
  • gem 1.35

The passenger-install-apache2-module command emits a script (while running it) with lot's of flags like -m32 and -march=i386. I've captured the script, replaced -m32 with -m64 and -march=i386 with -march=x86_64, re-ran it (with some extra include path and APXS2 variables) but the output object is still in 32 bit format.

Could someone share insight on how to force the 64-bitness upon the passenger?

edit: later I found out that any module I would try to compile would be built into a 32 bit version, so it's not specific to passenger

Thanks!

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Found an answer finally - uninstalling apr.i386 solved this problem

yum remove apr.i386
share|improve this answer
    
You should mark your answer as solved. –  Jonas Oct 28 '10 at 14:47
    
I was beating my brains out installing Passenger until I found this. Thank you! –  user5336 Feb 3 '11 at 3:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.