Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm still having trouble setting up my nameservers. DNS check says the following about my nameserver address:

Checking SOA records for domain. Domain server is not answering to UDP requests on port 53. Possible problems: A firewall is blocking port 53, server is down, server is not running software for handling dns requests.

I've run netstat -anp and found out that named is listening on tcp port 53, and it has udp port 53 on all IPs listed among active connections, though I'm unsure if that also means the port is actually active.

edit: This problem is now solved. Everything was configured correctly, the problem was in zone files which didn't have appropriate permissions, so named couldn't read them.

share|improve this question
    
Have you tried using nslookup from a remote computer to test your DNS server? –  Chris S Aug 24 '10 at 12:36
    
My registrar hasn't written the new nameservers into the DNS zone, because my server is not behaving like one (not answering the requests on UDP port 53). If I run nslookup on my IP (the one that should act as ns1) I get a Non-Authoritative answer. There are however authoritative answers from two IP addresses that are close in range to mine, but I don't see how this could help me. –  Primoz Aug 24 '10 at 13:07
    
I'm thinking. Should I create a reverse lookup zone for my server's IP? The external one I mean, the one for localhost is already set up. –  Primoz Aug 24 '10 at 16:49
    
Since you found your own answer, you should post that as an answer and then mark it as accepted please. –  Zoredache Aug 25 '10 at 0:45
    
I'd rather he accepted mine - it was the one that told him to go look in the BIND log file for the answer ... ;-) –  Alnitak Aug 25 '10 at 21:56
add comment

2 Answers

up vote 1 down vote accepted

I found what was wrong. The zone files had read permissions set only for root, so named couldn't open them.

share|improve this answer
add comment

From here, I get answers from your servers for the two .arpa zones, but SERVFAIL for the .si domain. Hence it's clearly not an IP stack or firewall problem.

Your BIND log file should tell you why that particular zone isn't working. FWIW, I ran your drustvo.zone file against the named-checkzone program and it said there were no errors.

share|improve this answer
    
Thanks for your effort, I found out what was the problem checking the logs when I restarted BIND. The zone files had read permissions set only for root, so named couldn't open them. Quite stupid, and to think I wasted a day o this... –  Primoz Aug 25 '10 at 0:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.