Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just installed latest ubuntu server edition on hyper-v r2. Install went good but i get no network connectivity.

I have a legacy network connection setup in hyper-v for that vm.

I setup static ip for that vm(everything looks good in interfaces file)

Nothing out of ordinary in ifconfig

but it is not connecting to anything?

Is there anything i am missing here?

Getting following error when start vm, looks some what related, no idea what it is

alt text

share|improve this question
add comment

4 Answers

up vote 2 down vote accepted

I had the same problem, Jeremy Hajek reminded me of the reason, thanks! Funny part is, I had this roblem only when I enabled more then one CPU in Hper-V Manager.

Udev sets the device name in newer versions of Ubuntu. Issuing 'ifconfig -a', you'll see all network interfaces, wether they are configured or not. I oticed that when I added the (standard) network adapeter, I forgot to disable the "legacy" network adaptor. For both I had set the same MAC address, this is what might have confused my config.

So:

  • make sure you only have one network adapter configured in Hyper-V Manager
  • configure eth0 in /etc/network/interfaces
  • delete /etc/udev/rules.d/70-persistent-net.rules (it will be re-generated on boot) so your only interface will really be called eth0
  • if you want to use all hyper-v modules at boot, append to /etc/initramfs-tools/modules

hv_vmbus

hv_blkvsc

hv_netvsc

hv_storvsc

(ignore blank lines)

  • rebuild initramfs: 'update-initramfs -u'

you should be done now, not addressing the smbios issue though. Does anyone know the full resulting kernel parameter?

share|improve this answer
add comment

I encountered this using vmware but worth a try as I think it is a Ubuntu response.

Possibly your network card information needs to be "bumped."
Use your favorite editor to edit this file /etc/network/interfaces
edit the file where it says eth0--try to change it to say eth1
then reset networking sudo /etc/init.d/networking restart and it should catch.

share|improve this answer
add comment

Ubuntu 10.04 should support running on a Hyper-V host with little to no trouble but you need to load the modules supporting synthetic devices and reconfigure networking accordingly.

Earlier versions or any Linux for that matter likely wants you to install the Hyper-V Linux Integration Services, though I have no idea if that's still required with the newer versions of the Linux kernel.

Also see this question.

share|improve this answer
add comment

Are you sure that the network device Hyper-V exposes to the guest is supported on Ubuntu?

Does ls /sys/class/net/ list any devices but lo?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.