Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a handful of Windows XP SP3 users whose mapped drives don't always appear in Windows Explorer when they initially log in. "net use" shows the drives are mapped correctly and they can see them in File Open dialogs in other applications. However they don't appear in Windows Explorer.

The current workaround we have is to kill Windows Explorer and then immediately start it again, then they do reliably appear.

Any ideas?

UPDATE: Still seeing this problem on some of our PCs. We're in the habit now of checking for any foreign DLLs being loaded into explorer.exe (Novell, Roxio, etc) and removing them, and making sure the PCs/users are in the correct OUs. This seems to solve the problem most of the time, but we've still got a number of PCs that won't show their network drives in My Computer when the PC first starts up even though they do show up in "net use" in a Command Prompt. But if you kill explorer.exe and launch it again, they do show up in My Computer. Anything else we should be checking for?

share|improve this question
    
I have a similar problem but with very few users. How are you mapping your drives? or are these being done manually? We're using Group Policy Preferences for all of them, and even though Always Wait for network is on, it seems like that setting not really working in the problem for us. Haven't found any fix for this yet. –  Jordan W. Feb 14 '11 at 18:48
    
Our drive mappings are created by Group Policy, but the thing is, the drives are mapping. They appear if you run "net use" in a Command Prompt, they just don't appear in My Computer. –  Alistair McMillan May 18 '12 at 15:28
    
Which version of Windows? XP? Vista? 7? –  Skyhawk May 18 '12 at 15:51
    
Can't believe I missed that out. Windows XP with SP3. Updated the question. –  Alistair McMillan May 18 '12 at 16:01

6 Answers 6

You might try enabling "Always wait for the network at computer startup and logon" via a group policy or manually with gpedit.msc. The setting is in Computer Configuration\Administrative Templates\System\Logon.

More info can be found here and here.

share|improve this answer
    
Just checked and "Always wait for the network at computer startup and logon" is enabled on all of our PCs, including the problem ones. –  Alistair McMillan Aug 25 '10 at 13:58

Are your users local admin of their workstations? If so, they may have installed a shell extension that is interfering with Explorer.

Try installing this:

http://www.nirsoft.net/utils/shexview.html

and disabling anything that looks unnecessary.

(Disclaimer: Never used this tool myself, but have seen various Windowsy people recommend it).

You could also try getting the user to log on to a known good workstation and see whether the issue occurs there.

share|improve this answer
1  
This pointed us in the right direction. Checked explorer.exe in Process Explorer and a bunch of Novell DLLs were loaded. We stopped using Novell a few months ago. Removed Novell completely from the PC and now network drives appear to be mapping correctly. Thanks. –  Alistair McMillan Feb 21 '11 at 15:02

It's a bit of a long shot, but could it be that the mapped drives are empty? One of explorer's folder options is to 'Hide empty drives in the Computer folder' - this is set 'on' by default.

share|improve this answer
    
Thanks but no. Mapped drives are definitely not empty. –  Alistair McMillan Aug 25 '10 at 11:58

Hi I hope this is the solution to your problem:

http://support.microsoft.com/kb/297694

It may not be, but there isn't enough information in your post to be sure. Please try the workaround section, and if it does work best to call microsoft for a hot fix.

share|improve this answer
    
Should have mentioned our PCs have all been upgraded to Service Pack 3 which includes this fix. –  Alistair McMillan Feb 21 '11 at 8:05
    
support.microsoft.com/kb/961187 This article states that if the problem is there applying sp3 doesnt fix it. Note This problem does not occur if you previously installed hotfix KB297694 or applied Windows XP Service Pack 3 (SP3). However, if this problem occurs before you install hotfix KB297694 or apply Windows XP SP3, you cannot resolve this problem by installing the hotfix or by applying Windows XP SP3. –  pablo Feb 22 '11 at 10:26
    
Different bug. That bug is about "...a collision with the existing mapped network drive". That isn't the case here, the drives are mapped to available drive letters. They show fine in a command prompt, they just don't show in Windows Explorer. –  Alistair McMillan Oct 10 '11 at 8:23

I found this on another serverfault.com post.

net use x: \\computer name\share name /PERSISTENT:YES

the persistent should make it appear in explorer. worth a shot :)

share|improve this answer
    
Thanks but I don't think it is this. The mapping is being made and is available, it just isn't showing in Windows Explorer. –  Alistair McMillan Aug 25 '10 at 11:31

I have about the same problem where a network map drive cannot be seen with Windows explorer but can be located and accessed from the DOS prompt. I was also able to access the map drive (z:) when I ran explorer from the DOS prompt like --> explorer z: If I just ran explorer.exe it does not see the mapped network drive. Desktop PC: Window 7 (64) SP1 Server: Windows server 2008 The user installed Spybot but later removed it because it was causing him other issues. Not sure if something left over from this caused the issue

share|improve this answer
    
Russ Hughes, welcome to Server Fault! Since your post doesn't answer the original question, would you please edit it to conform to the guidelines - "How to answer"? –  Deer Hunter Jan 16 '13 at 18:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.