Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to install magento 1.4.1.1 on a fresh install of zend server 5.0.1 on a windows 7 32 bits machine with apache and so far it's only failures.

I quickly realize it needed an increased max exec time to i raised it to 600. but after that i can see tables in the database and all but the execution stops in a certain point and firefox prompts for saving of a file (of type application/x-httpd-php) which saves as QxQxa4wp.part.

i opened the file in firefox and it displays

OK

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later

the zend server php error log is like this

[25-Aug-2010 10:50:52] PHP Notice: Zend Utils: user restart request received, restarting in on line 0

the server error log is like a lot of this very same line

[Wed Aug 25 11:15:41 2010] [error] [client 127.0.0.1] File does not exist: C:/Program Files/Zend/Apache2/htdocs/ZendServer

so ZendServer is rather under C:/Program Files/Zend/ and not the path in the error log.apache2 and ZendServer are siblings folders.

I managed to show the errors and here is what it says

Error in file: "C:\Program Files\Zend\Apache2\htdocs\magento\app\code\core\Mage\CatalogInventory\sql\cataloginventory_setup\mysql4-install-0.7.0.php" - SQLSTATE[42S01]: Base table or view already exists: 1050 Table 'cataloginventory_stock' already exists

Trace: 0 C:\Program Files\Zend\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(390): Mage::exception('Mage_Core', 'Error in file: ...') 1 C:\Program Files\Zend\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(276): Mage_Core_Model_Resource_Setup->_modifyResourceDb('install', '', '0.7.8') 2 C:\Program Files\Zend\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(240): Mage_Core_Model_Resource_Setup->_installResourceDb('0.7.8') 3 C:\Program Files\Zend\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php(161): Mage_Core_Model_Resource_Setup->applyUpdates() 4 C:\Program Files\Zend\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\App.php(363): Mage_Core_Model_Resource_Setup::applyAllUpdates() 5 C:\Program Files\Zend\Apache2\htdocs\magento\app\code\core\Mage\Core\Model\App.php(295): Mage_Core_Model_App->_initModules() 6 C:\Program Files\Zend\Apache2\htdocs\magento\app\Mage.php(596): Mage_Core_Model_App->run(Array) 7 C:\Program Files\Zend\Apache2\htdocs\magento\index.php(80): Mage::run('', 'store') 8 {main}

any ideas on how to fix this issue or i should just try the latest but one stable version.

share|improve this question

migrated from stackoverflow.com Aug 25 '10 at 13:56

This question came from our site for professional and enthusiast programmers.

    
This may be better suited for ServerFault. –  Chuck Burgess Aug 25 '10 at 13:48

1 Answer 1

up vote 0 down vote accepted

I solve this by using virtualhost and have magento as ZendServer sibling folder.works fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.