Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So after following the Ubuntu Postfix tutorial, I tried their recommended test

telnet localhost 25
MAIL FROM: person@mydomain.com
RCTP TO: person@gmail.com
DATA
some text here
.

I received a successful 250 OK Queued as C55230429543

However, when I checked my gmail account (including spam folders) there was no e-mail there.

Any ideas where I can check to see where things went wrong?

Aug 25 22:34:06 mydomain postfix/cleanup[16130]: 23C20508CA: message-id=<20100825223401.23C20508CA@server1.mydomain.com>
Aug 25 22:34:06 mydomain postfix/qmgr[15822]: 23C20508CA: from=<root@mydomain.com>, size=372, nrcpt=1 (queue active)
Aug 25 22:34:12 mydomain postfix/smtp[16131]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 25 22:34:13 mydomain postfix/master[15819]: warning: process /usr/lib/postfix/smtp pid 16131 exit status 1
Aug 25 22:34:13 mydomain postfix/master[15819]: warning: /usr/lib/postfix/smtp: bad command startup -- throttling
Aug 25 22:34:35 mydomain postfix/smtpd[16127]: disconnect from localhost[127.0.0.

I changed my actual domain to 'mydomain'

share|improve this question
    
please provide a snippet of /var/log/mail.log and the result of mailq –  Andreas Rehm Aug 25 '10 at 22:32
    
added a snippet of the mail.log... Where can I find the result of mailq? –  ThinkingInBits Aug 25 '10 at 22:37

2 Answers 2

A little search on Google for fatal: specify a password table via the smtp_sasl_password_maps would lead you to this page. On page 3, you will find that:

Apr 14 18:03:08 flamingweasel postfix/smtp[17932]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter

is due to a typo in your configuration that goes undetected. The line you have is:

smtp_sasl_auth_enable = yes

Where you want it to be:

smtpd_sasl_auth_enable = yes

And if you don't have this line, you're probably missing it.

share|improve this answer

I would suggest that you start by reading the message and acting on it. Especially the bit where it says:

fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter`.
share|improve this answer
    
I followed this tutorial: help.ubuntu.com/community/MailServer it never mentioned anything about password maps. I'm new to this, where does the password table live? –  ThinkingInBits Aug 25 '10 at 23:00
1  
Well, evidently you configured sasl without knowing it. You either need to finish configuring it, or disable it. –  Paul Tomblin Aug 26 '10 at 0:24
    
I configured SASL based on the guide above... I configured it exactly how it states in the guide –  ThinkingInBits Aug 26 '10 at 0:31
    
Obviously not exactly, or it would be working, wouldn't it? –  Paul Tomblin Aug 26 '10 at 11:08
2  
@ThinkingInBits Countless guides don't work out-of-the-box and need to be adapted. –  ℝaphink Aug 27 '10 at 20:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.