Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to setup a VPN on my small home network (windows 2003). My home Vista machine is returning me Error 806 and is saying something about enabling the GRE protocol.

I have one nic inside my windows 2003 machine. It has a static ip of 192.168.1.110

Things I have done

  • I was able to setup the VPN through the Configure Your Server Wizard.
  • I have enabled port 1723 through my router.

When I try to run Windows Firewall for Win2k3 I get a nice message telling me that Windows Firewall cannot run because another program or service is running that might use the network address translation component (Ipnat.sys)

I then went into Routing and Remote Access and from there I am completely lost.

Any help would be greatly appreciated. I was having some bad luck with Google other than finding this great site.

share|improve this question

3 Answers 3

In addition to TCP port 1723, you're going to need to enable IP protocol 47 to pass through your router/firewall -- this is for GRE, and could be the source of the error.

Can you describe your network further? You have a windows 2003 box w/ one NIC, so it sounds like it's connected directly to your router which is performing nat and has firewalling capability (which is what you've enabled port 1723 to be forwarded through)? Is this about right?

Additionally, is there any security software (i.e., a suite with a personal firewall) installed on the box that may be interfering with the windows firewall?

share|improve this answer
    
1) That is correct, the windows server is connected to my router 2) Currently no other security software installed, I also disabled my firewall on my vista machine to take out that variable for now. –  Ryan Jun 2 '09 at 11:35

There are quite a few things to setup. Here is the site I used as a reference when I setup mine. http://www.howtonetworking.com/VPN/2003vpn11.htm

share|improve this answer

Not every router supports the GRE protocol. You might want to check first to see if it's something your hardware/current firmware version can support.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.