Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two Dell PowerConnect switches I want to connect together via Port-Channel links (2 ethernet links).

Spanning tree is enabled on both switches, so therefore applied to all interfaces unless otherwise specified.

Here is the configuration I would expect to work, but doesn't.

Switch A - Dell 6248

interface ethernet 3/g21
channel-group 39 mode auto

interface ethernet 3/g22
channel-group 39 mode auto

interface port-channel 39

Switch B - Dell 5424

interface ethernet g18
channel-group 4 mode auto

interface ethernet g19
channel-group 4 mode auto

interface port-channel 4

As you can see there is no specific config applied to each port channel. When I connect everything up using this configuration, I get no communication between the two switches. Output of show spanning-tree follows:

Switch A - Dell 6248

Port ch39    Enabled
State: Discarding                                Role: Designated
Port id: 128.664                                 Port Cost: 10000
Port Fast:  No (Configured: no )                 Root Protection: No
Designated bridge Priority: 16384                Address: 40:00:00:25:64:25:B6:82
Designated port id: 128.664                      Designated path cost: 0
CST Regional Root: 10:00:00:25:64:25:B6:91       CST Port Cost: 1000
Root Guard..................................... FALSE
Loop Guard..................................... FALSE
TCN Guard...................................... FALSE
BPDU: sent 1260, received 1226

Switch B - Dell 5424

Port ch4 enabled
State: forwarding                              Role: designated
Port id:  128.52                               Port cost: 4
Type: P2P    (configured:Auto  ) RSTP          Port Fast: No (configured:No)
Designated bridge Priority : 32768             Address: 00:23:ae:d6:a5:77
Designated port id: 128.52                     Designated path cost: 4
Guard root: Disabled                           BPDU guard: Disabled
Number of transitions to forwarding state: 1
BPDU: sent 3715, received 0

As you can see, with spanning tree enabled everywhere, Switch A's port-channel goes into discarding state.

If I disable spanning tree on Switch A communication between two switches works.

interface port-channel 39
spanning-tree disable

So two questions:

  1. Is there something I am missing in the config that I need to fix so spanning-tree will allow traffic through.
  2. Should I just disable spanning tree on the port-channel on Switch A and stop worrying about this?
share|improve this question

3 Answers 3

up vote 1 down vote accepted

I would first try to set it up without a channel-group, just one interface and see if that works. It seems that the STP isn't communicating properly - you really don't want to just turn it off because that will just create problems later.

share|improve this answer
    
Ended up doing this. We had all kinds of problems because we had MSTP set up on our Cisco switches, and this was not noticed by the consultants who installed the Dell switches, which didn't have MSTP set up. Dell switches at core, so unless everything stopped working we weren't in a position to experiment. I got promoted and it is no longer in my sphere of interest... –  dunxd Mar 14 '12 at 21:44

were you cable in place when make the configuration? Try shutting down the port-channel on both ends and then re-enable them.

share|improve this answer

Did you try 'mode on' to force the LAG instead of negotiating it with LACP?

Can you investigate putting the 6248 in to RSTP mode? It should be RSTP by default but it doesn't say so.

Is it possible you have a loop somewhere else already linking these switches?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.