Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a copy of Ubuntu 10.04 [Desktop] LTS running inside a virtual machine using VMWare workstation on a Win 7 host sitting behind an ISA Server on a corparte network.

I am unable to connect to the outside world from this VM except through a web browser. I cant use apt-get, ruby gems (install off the network) or any other command line or GUI program.

So far I have tried setting up proxy on the network proxy page, /etc/bash.bashrc file using export http_proxy:{my proxy details}, in synaptics update manager, using cntlm and changing individual however none of these seem to work and give me an outside connection.

Now here is the kicker, on the same computer and network I have VirtualBox setup with a clean install of Ubuntu 10.04 and it connects to outside with no problems. Both VM's are set to use NAT.

The host has an ISA Client installed and allows Win 7 to operate correctly

Does anyone know why I can connect using VirtualBox but not VMWare workstation and how i can get VMWare to work on network.

Kind Regards Colin G

share|improve this question
have you tested your clean installation vm in VMware? – krissi Aug 30 '10 at 12:35
If you post your VM config files (.vmx for the VMware, .xml for the VirtualBox), that may help us diagnose your problem. Also, please post the results of an ifconfig on each box. The results of a traceroute to the IP of your ISA Server may help – gWaldo Sep 2 '10 at 12:07

I don't know why you would have this working in VirtualBox and not VMWare, but I can say when we used ISA it was a finicky mistress with machines that weren't joined to the domain (and even *nix ones that were joined with likewise or samba). We used NTLMAPS for our GNU/Linux hosts (mostly Ubuntu servers), as for whatever reason this worked far better for us than cntlm.

It's easy enough to try: apt-get install ntlmaps, tweak the /etc/ntlmaps/server.cfg file and enter proxy, user, and domain information, and in particular set LM_PART to 0 and NT_PART to 1 unless your domain is really old. To get apt to use this, add a file called 01proxy to /etc/apt/apt.conf.d/ with the following line:

Acquire::http::Proxy "";
share|improve this answer

Are you certain that both the VMware and the VirtualBox VMs are using the same type of networking (bridged vs NAT vs etc)? Verify that they're on the same network via ifconfig.

share|improve this answer
+1 vote for showing us the ifconfigs. – JakeRobinson Aug 31 '10 at 18:07

Has vmware tools been installed on the Ubuntu guest? What version of workstation? Was this a clone from virtualbox to vmware (ie the same vm) or a brand new install? Anything interesting in /var/log/messages?

share|improve this answer

There are a few steps you can take to try to correct your problem here, give this a shot

  1. check the VM networking on your vmware workstation. Make sure you select "Bridged".
  2. start your vm and go to the networking part of ubuntu and edit it, Give it an IP, if you are running DHCP on your current network then set it to dhcp, if not configure the IP like how you would configure any other machine on your network. Give it an ip, netmask and your default gateway ( NOTE: gateway here is not your win.7 machine but your true network gateway)
  3. Open a shell and test to ping the internet. "ping" would be a safe bet. If all goes well you should be out into the net by now. If you are still facing problems read on...
  4. IF you are still facing problems here, go back to the VMware workstation setup, under "Bridged" check the "Replicate physical Network State"

For whatever reason if you do not want to follow the steps above, just my 2 Cents - if you are using a DIRECT connection out to the internet from the Win. 7 machine, NAT would be easier and the way to go. I have faced this problem over and over again, I decided not to waste anymore of my time toying on how to fix the VMware NAT and decided to go with the option on top. Hope this helps.

share|improve this answer

I could not use the host's Cntlm server in the client because I was using the wrong source IP address. If VMware is using NAT (which is how my virtual machine is configured), Cntlm has to listen to the host's IP address in the virtual VMware network, not to the host's IP in the corporate network.

The following commands were executed on the host.

$> ifconfig | grep -e "inet " -e " Link"
eth0      Link encap:Ethernet  HWaddr ....
          inet addr:  Bcast:  Mask:
lo        Link encap:Local Loopback  
          inet addr:  Mask:
vmnet1    Link encap:Ethernet  HWaddr ....
          inet addr:  Bcast:  Mask:
vmnet8    Link encap:Ethernet  HWaddr ....
          inet addr:  Bcast:  Mask:
wlan1     Link encap:Ethernet  HWaddr ....

This is what did NOT work (i.e. the client had no access to the Cntlm server):

cntlm -v -g -l localhost:1118 -u -I

This is what worked:

cntlm -v -g -l -u -I
share|improve this answer

You probably need a proxy that supports NTLM authentication to get through ISA. I have no personal experience with this, but one of these packages might be useful.

share|improve this answer
Hm, I see you already tried cntlm now... – JanC Aug 30 '10 at 15:30

If im not entirely wrong there should be a firewall included in vm-ware(not sure about workstation). Try to disable that one. Unfortunately I don't have any vmware workstation install to confirm my suspicions.

Im guessing the main problem here is that you get full access from virtualbox and almost none from vmware.


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.