Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Sorry for the newbie question, but I'm having issues with tasksel.

I tried to install lamp-server, but php5 isn't installed.

user@host:/var/www$ aptitude show apache2 | grep -i installed
State: installed
Automatically installed: no
user@host:/var/www$ aptitude show mysql-server | grep -i installed
State: installed
Automatically installed: no
user@host:/var/www$ aptitude show php5 | grep -i installed
State: not installed
 This package is a metapackage that, when installed, guarantees that you have at
 least one of the three server-side versions of the PHP5 interpreter installed.
user@host:/var/www$

In the above, I'm in /var/www because I created an info.php file to see if there was possibly some other version of php running I wasn't aware of, but there's not.

During installation, I had to fill out items for mysql (root password), and if I try to connect to the webserver, I get apache's "It works!" page, but there's no sign of php anywhere, and I can't figure why.

I've never used tasksel before, so I could be misunderstanding something, but could someone let me know what I did wrong?

I'm using Ubuntu 10.04 Server.

share|improve this question
add comment

3 Answers

If you try sudo apt-get -f install, does the prompt just return or does your server continue configuring packages? If something interrupted your previous installation attempt, it might be half-finished.

share|improve this answer
    
No, it's clean. Tasksel didn't kick out any errors when I ran it before either, that I know of. I just tabbed back to my VM and it was sitting at the bash prompt awaiting orders. –  Steve Aug 26 '10 at 18:35
    
Weird. How about "dpkg -l | grep php", does it return something? –  Janne Pikkarainen Aug 26 '10 at 18:38
    
libapache2-mod-php, php5-common, and php5-mysql are listed as installed there –  Steve Aug 26 '10 at 18:45
    
I just tried aptitude install php5 -s and the only thing it found to install was the php5 package itself, saying "20.5kB will be used." I find it odd that a) it would install everything but the meta package, and b) that the metapackage itself would prevent it from working even though the components were all there. Maybe I should just install it (note that i used -s to simulate the install, not actually install it). I'd rather know what went wrong than to just patch it, in case I run into similar issues when I create the production version –  Steve Aug 26 '10 at 18:52
    
So PHP5 is installed on your system (and you don't need the meta-package). If it doesn't work that sounds more like a configuration or permission issue. –  JanC Aug 27 '10 at 15:20
show 2 more comments

I had this same thing happen. php5 and one more 'lib' something were not installed even as the system thought they were. So if I went to install, it 'was already there', if I tried to uninstall it 'didn't exist'. I had to use purge and reinstall specifically.

Something similar seems to be up with php5-suhosin, where my error log seems to think its installed, but actually it isn't.

share|improve this answer
add comment

I have experienced same problem when ondrej's PPA was configured to be used. If you have it, remove the PPA, install lamp-server through tasksel, then add PPA and upgrade PHP.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.