Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a 16 GB iPad wifi I can't get to connect to VPN. The error I get is: "A connection could not be established to the PP server. Try reconnecting. If the problem continues, verify your settings and contact your Administrator."

I have tried a variety of tasks to troubleshoot the issue:

  • I have verified that another iPad on another network can connect to the VPN I am trying to connect to
  • I can connect to this VPN from the same network the iPad uses on a Windows machine
  • I have verified an iPhone user can connect to this VPN from a different network
  • I have reset the iPad's network settings
  • I have reset the entire iPad and restored settings
  • I have compared my settings w/ a screenshot from the iPad that works and confirmed everything is correct
  • I have used the IP address and domain name of our VPN server in the settings
  • I have tried deleting the VPN settings in the iPad and recreating them
  • I have verified in the logs of VPN server that I'm not even getting to the VPN server (no log entry)
  • I have verified that I cannot VPN from the iPad on separate network (different ISP and router)

Are there any other ways to troubleshoot VPN on an iPad?

share|improve this question
Sounds like you have tried a lot of various scenarios. At this point you may need to watch the connection with tcpdump or some other capture tool. – Zoredache Aug 26 '10 at 21:35

If you're trying to do this over 3G, be aware that AT&T's network will block VPN access (outbound) unless you have their Enterprise Data Plan.

share|improve this answer
Clarified. This is a wifi iPad. – Justin Aug 26 '10 at 22:07

Seems to be NAT traversal problem? You mentioned 'separate network' I'm assuming that the iPhone VPN and iPad VPN have been tested on wifi from the same 'separate network'. That would rule out NAT traversal if the iPhone connected. Otherwise, as I read it, if your 'different network' and 'separate network' mentioned above are different networks, it should be a local configuration issue. If that makes sense...

Side note: apparently I don't have enough to comment on pjz's post, but as a clarification I run VPN over 3G with no trouble whatsoever (and non-enterprise AT&T account).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.