Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running FreeBSD 7. running MySQL 5.1.36 from ports.

I am trying to check some data in the MySQL binary log files, and I get the following error:

# mysqlbinlog mysql-bin.000021
mysqlbinlog: unknown option '--ssl'

In addition, I can't even view the help for this command:

# mysqlbinlog --help
mysqlbinlog: unknown option '--ssl'

Why does mysqlbinlog not know about the option ssl?

This server was compiled with SSL, and ssl is activated in the my.cnf configuration file. We use SSL for remote connections, but I am running this command on the local host.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

I recently ran into the same problem with MySQL 5.1.41 on Windows. The mysqlbinlog program doesn't support the --ssl option, but I couldn't figure out where it was reading that option. Even when I commented out the SSL options under [mysqld] in my.ini, mysqlbinlog was still reading that option somewhere.

Eventually I found that my.ini had a [client] section that was specifying the --ssl option:

[client]
ssl
ssl-ca=C:/certificates/MySQLCerts/ca-cert.pem
port=3306

I commented out those ssl options and then mysqlbinlog worked:

[client]
#ssl
#ssl-ca=C:/certificates/MySQLCerts/ca-cert.pem
port=3306

I did not have to restart MySQL for the changes to take effect.

share|improve this answer
    
Thanks for finding the root cause. Too bad that the [client] options don't work with mysqlbinlog. I need those options for the regular mysql commandline tool. –  Stefan Lasiewski Sep 5 '13 at 17:08
add comment

As a workaround to this problem, I figured out that I can skip the defaults:

mysqlbinlog --no-defaults
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.