Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Uniserver on windows 7, and it's been extremely difficult so far.

At first, only files in subdirectories would not run properly. Now though (after a restart), all files do not work.

Basically, instead of running, the source file is downloaded in my browser (unless the server isn't on - then I simply get the "Problem Loading Page" message).

When it was working, other problems occured, such as include files being echo'd instead of run.

Can someone guide me w/ regards to getting Uniserver to run cleanly and properly?

Thanks!


Edit:

Now when I browse to http://localhost, it shows a directory browsing interface like this: http://www.gobalakrishnan.com/wp-content/uploads/2008/04/directory-browsing.jpg

Edit: I reinstalled Uniserver and it's the same, except now the admin panel is working!

share|improve this question
up vote 0 down vote accepted

That's literally what you get when all you do is browse to http://localhost/ and NOTHING else?

I believe this means that you have a redirect either in the core Apache configuration, or in your private .htaccess file, because you're being taken all the way into a WordPress directory that's not meant to be directly accessed.

Two Solutions to this current problem:

(1) Review your .htaccess file (perhaps temporarily rename it, or delete it AFTER MAKING A BACKUP!!!!
(2) Turn off "indexes" or "Directory indexes" (indexing?) in the Uniserver configuration.

share|improve this answer

Your image looks to me like you dis-configured virtual dir in IIS.

Try in IIS to uncheck "Directory browsing" checkbox
Also, configure your browser to permit running active content/ scripts, etc.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.