Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to get private IPs set up with my Linodes. I'm running Debian. Here's my Linode's Network tab:

eth0:            69.164.214.146
                 ( li129-146.members.linode.com )
Gateways:        69.164.214.1
Netmask:         255.255.255.0
Private eth0:    192.168.140.217
Netmask:         255.255.128.0
DNS Servers:     97.107.133.4
                 207.192.69.4
                 207.192.69.5

and here's my /etc/network/interfaces file:

auto lo
iface lo inet loopback

auto eth0 eth0:0
iface eth0 inet static
 address 69.164.214.146
 netmask 255.255.255.0
 gateway 69.164.214.1

iface eth0:0 inet static
 address 192.168.140.217
 netmask 255.255.128.0

On the linode I'm setting up, I can ping 192.168.140.217 just fine. The other linode will not, though.

Yes, the other Linode is in the same data center.

Perhaps there is something I need to do with iptables? Perhaps my configuration isn't right? Any help is appreciated.

share|improve this question
    
Have you restarted your linode since adding the private IP? If that doesn't work just send in a support ticket - the linode staff are great and they'll get this working for you in no time. –  EEAA Aug 28 '10 at 4:21

1 Answer 1

up vote 5 down vote accepted

The problem was that both Linodes require the private IP address to be installed. Having only one ruptured the space-time continuum and disturbed life as we know it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.