Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a backup system with s3fs and the Amazon S3 service. I followed this this guide and this guide.

Tailing /var/log/messages I get:

Aug 28 13:37:46 server s3fs:###response=403

I already tried creating the authentication file /etc/passwd-s3fs and setting the access and private key, passing it through the command line. I checked several times the credentials and I used it with s3fox, and it is working.

I also have set the time of the machine (with the date command) to be the same as the Amazon S3 servers (I got the time of the S3 server uploading a file with the file manager).

Not only does rsync not work, commands like ls or cp in /mnt/s3 didn't work also.

share|improve this question

2 Answers 2

triple check the credentials in /etc/passwd-s3fs

also, be sure the bucket name you're using is your bucket name (i.e., it is unique to you) (i.e., don't use a bucket name "test" or something like that because it is unlikely that you own/claimed the bucket name; bucket names are in a global namespace with everyone else's bucket names)

also, s3fs does not create buckets; you would need to use another s3 tool to create the bucket first, and then mount it with s3fs

share|improve this answer
    
all of that has been checked, and it still didn't worked –  shadow_of__soul Aug 31 '10 at 2:32

You can actually store the credentials in two places. System level or user level. Not clear from your question where you have things set. Each requires different permission settings.

For system level placement in /etc/passwd-s3fs the permissions should be 640. So adjust with chmod like so if that is not the case:

sudo chmod 640 /etc/passwd-s3fs

For user level placement in ~/.passwd-s3fs the permissions should be 600. So adjust with chmod like so if that is not the case:

chmod 600 ~/.passwd-s3fs

Also, the contents of each of those files should follow the fairly simple format of AccessKey:SuperSecretKey with nothing else needed. AccessKey on one side of the colon (:) ad the SuperSecretKey on the other side.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.