Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've setup a mongrel_rails cluster which worked correctly until I decided to reinstall ruby/rails/mongrel.

I'm able to get an output when I visit the website, but I'm obtaining the page source instead of a parsed html file...

From what I understand, the returned header is incorrect:

Date: Sat, 28 Aug 2010 17:19:21 GMT
Content-Length: 17374
Keep-Alive: timeout=2, max=100
Connection: Keep-Alive
Content-Type: text/plain

200 OK

when I should receive something like (returned by a thin instance)

Date: Sat, 28 Aug 2010 17:20:32 GMT
Server: thin 1.2.7 codename No Hup
Etag: "48db41ed4b0969cd6239c36dec57198d"
Content-Type: text/html; charset=utf-8
X-Runtime: 1483
Content-Length: 5250
Cache-Control: private, max-age=0, must-revalidate

200 OK

Is there any setting in mongrel/apache (mongrel is behind a proxy) I should modify to fix this?

Relevant gems installed version: mongrel (1.1.5) mongrel_cluster (1.0.5) rails (2.3.8, 2.3.5) thin (1.2.7)

share|improve this question

1 Answer 1

Solved this by using a solution provided @ https://rails.lighthouseapp.com/projects/8994/tickets/4690.

Given by Matthew Denner June 25th, 2010 @ 12:15 PM

By adding the following two lines (to lib/mongrel/cgi.rb, around line 80):

@head['cookie'] = options['cookie'] if options['cookie']
options.delete('cookie')

before:

REMOVED_KEYS.each {|k| options.delete(k) }
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.