Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I run a local copy of Weblogic, I like to see the output in the console so that I can observe my app's logging messages. But, Weblogic spits out a lot of log messages I don't care about, like these:

[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)' 08-29-2010 01:02:21 INFO Getting a JNDI connection
[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)' 08-29-2010 01:02:21 INFO Connection Returned.  Elapsed time to acquire=0ms.
[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)' 08-29-2010 01:02:21 INFO Getting a JNDI connection
[ACTIVE] ExecuteThread: '0' for queue: 'weblogic.kernel.Default (self-tuning)' 08-29-2010 01:02:21 INFO Connection Returned.  Elapsed time to acquire=0ms.

Can I configure Weblogic to not output those? I assume that I can change the logging level to something higher than INFO and that should fix it?

share|improve this question

2 Answers 2

You can disable the "Redirect stdout logging enabled" option to avoid most of WebLogic logging in sysout. Only low-level (java/system errors) should go to system output. I suggest to not use stdout (java System.out.println and related methods) to log server applications messages because the management of the resulting logs is difficult and system-dependent. Instead use ad-hoc logging frameworks like log4j, java.util.logging, Apache commons logging, ...

share|improve this answer

You can try changing the severity as described here

http://download.oracle.com/docs/cd/E12840_01/wls/docs103/logging/logging_services.html#wp1181596

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.