Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Environment:

  • Windows Server 2003 R2 Standard x64 Service Pack 2
  • SQL Server 2005 SP2 (9.00.3077.00) Enterprise Edition (64-bit)

Trying to install and execute an SSIS package on a development environment, getting the following error:

Executed as user: NIHR\svcaccsqlagent. ....00.3042.00 for 32-bit Copyright (C) Microsoft Corp 1984-2005. All rights reserved. Started: 11:50:53 Error: 2009-06-02 11:50:56.28 Code: 0xC0010018 Source: Description: Error loading value "PCRN Data Update Batch Log0SSIS log provider for T" from node "DTS:LogProvider". End Error Could not load package "E:\PCRN_SSIS\PCRN Data Update Batch.dtsx" because of error 0xC0010014. Description: The package failed to load due to error 0xC0010014 "One or more error occurred. There should be more specific errors preceding this one that explains the details of the errors. This message is used as a return value from functions that encounter errors.". This occurs when CPackage::LoadFromXML fails. Source: Start... Process Exit Code 5. The step failed.

Any ideas? The same package is working fine on a production environment, I can't tell what's different.

share|improve this question
    
Anything special about it? DTS? JET DB Access? –  Sam Jun 2 '09 at 14:46
add comment

3 Answers 3

Does your SSIS package contain a DateTime type variable?

Read this Microsoft support article:

You receive an error message when you try to load an SSIS package that contains a DateTime type variable in SQL Server 2005

This problem occurs because the value of the DateTime variable is saved in string format when you save the SSIS package. However, the string representation of the DateTime variable is based on the date format that is specified in the Windows locale. Therefore, when you try to load the SSIS package on a computer that has an incompatible locale date format, the operation fails.

Solutions:

Manually update the DateTime type string in the SSIS package to use the slash (/) character as the date separator

or

Update the date separator in the Windows locale setting to be identical to the date separator of variables in the SSIS package file.

share|improve this answer
add comment

Looks like you are trying to run a 32 bit package on a 64bit server, by default the 32 are not installed

on a 64-bit computer, selecting Integration Services during Setup installs only the 64-bit runtime and tools. If you have to run packages in 32-bit mode, you must also select an additional option to install the 32-bit runtime and tools:

* If the 64-bit computer is running the x86 operating system, select Business Intelligence Development Studio or Management Tools - Complete.
* If the 64-bit computer is running the Itanium operating system, select Management Tools - Complete.
share|improve this answer
add comment

If you run the dtexec command manually from a command line passing it the same parameters that the SQL Agent is passsing it you should get more error information.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.