Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I know this is almost embarrassing, but it happened to me anyway.

I have a server here running Fedora 10, with sendmail (8.14.3) on it. The MTA is only used to send messages from the localhost to a smarthost. This used to work fine, except I needed to change that smarthost, as it has been replaced by another machine with different IP address and different DNS name (during the course of an internal streamlining effort).

I followed some instructions I found on a forum somewhere and added a line to the mailertable, like this: ESMTP:[]
where is the name of the internal smarthost.

Then I used the m4 utility to create new .cf files and restarted sendmail. And bang, I get the following error:

service sendmail restart
Shutting down sm-client:                                   [FAILED]
Shutting down sendmail:                                    [  OK  ]
Starting sendmail:                                         [  OK  ]
Starting sm-client: No local mailer defined
QueueDirectory (Q) option must be set

I have googled this, but I come up mostly with forum posts that nobody responded to.

According to, the QueueDirectory is defined. And there seems to be next to no information available anywhere as to how to define a local mailer???? Plus: when I use the m4 utility to also re-create, the resulting file is not accepted and throws an error like this:

Starting sm-client: /etc/mail/ line 0: invalid argument to V line: "ERSIONID(linux setup"

And this, even though the file is exactly the same as on another server (also running Fedora 10 with sendmail), where everything works perfectly fine.

Ideally I would love to just ditch sendmail altogether and use exim, but in this particular case I haven't got that choice. So, could anybody please point me in the right direction?

share|improve this question
up vote 3 down vote accepted

I have found a solution. Not sure whether this is what I am supposed to do or not, but it works anyway.

After running either

make all



I simply did


then restarted sendmail, and it all works fine. Strange that there's not really any documentation about this anywhere.

share|improve this answer

After some googling, I found this article and since it did help me I wanted to post what worked. I ran into this error with Rhel4 when attempting to perform:


/etc/mail/ line 1: invalid argument to V line: "ERSIONID(linux setup" Warning: .cf file is out of date: sendmail 8.13.1 supports version 10, .cf file is version 0 No local mailer defined QueueDirectory (Q) option must be set

by performing the : cp (Suggestion from here) this fixed the issue and now I am able to send mail using mailx again.

as a side note the server did not have sendmail-cf pkg installed either.

hope this helps, and just wanted to say "thanks" for those steps to try.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.