Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There is no apt-get install php5-sqlite3, as its refereed by php5-sqlite

thus, i did:

apt-get install sqlite3 and then apt-get install php5-sqlite

Restarted apache2.

When I run echo sqlite_libversion(); it returns 2.8.17.

I tried print_r(SQLite3::version()); and it gives an error: Class 'SQLite3' not found

share|improve this question
up vote 1 down vote accepted

Sqlite3 comes as part of PHP 5.3.x. The packaged Debian version of of PHP5 in Debian Lenny is based on 5.2.6.

From a quick google search I don't see a way to backport this. To access sqlite3 functionality on 5.2.6 you can use PDO. If that is not acceptable, then you probably will need to find/use/build a backport of PHP.

share|improve this answer
1 suggests the version in Debian Squeeze is new enough to have SQLite3 embedded, so you could backport that package. Bear in mind that you'll have to backport security updates by hand until Squeeze releases though. – David North Aug 31 '10 at 20:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.