Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

All,

Sorry in advance - I'm pretty naive when it comes to these things.

Anyway, I'm trying to install the Pear Mail module.

So, from the command line, I try this:

pear install --alldeps Mail

Here's the error I receive:

WARNING: channel "pear.php.net" has updated its protocols, use "channel-update pear.php.net" to update
pear/Mail requires PEAR Installer (version >= 1.5.6), installed version is 1.5.0
No valid packages found
install failed

So, to upgrade the installer, I tried this:

pear upgrade PEAR

Here's the message I receive:

WARNING: channel "pear.php.net" has updated its protocols, use "channel-update pear.php.net" to update
pear/Archive_Tar requires PEAR Installer (version >= 1.5.4), installed version is 1.5.0
pear/PEAR dependency package "pear/Archive_Tar" installed version 1.3.2 is not the recommended version 1.3.7, but may be compatible, use --force to install
No valid packages found
upgrade failed

What should I try next to upgrade the installer to at least 1.5.6?

Many thanks in advance!

Cheers, Matt Stuehler

share|improve this question
add comment

2 Answers 2

First: pear upgrade --force pear

Then: pear install --alldeps Mail

This just worked for me on MT (dv) 3.5.

share|improve this answer
add comment

Not sure if this applies to (dv) as well, but on (gs) one has to set the command line to PHP 5 instead of the default of 4 for PEAR to work:

http://wiki.mediatemple.net/w/%28gs%29:Set_specific_PHP_version_for_command_line

Note that this action is different from setting the PHP version of your domains inside the MT control panel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.