Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Sql 2008 r2 DEVeloper on Windows 2008 STD. It previously had Sql 2008 Enterprise installed. I first uninstalled SQL 2008. I think uninstall still leaves some crap in registery, and in Program files.

Installation fails in the last step of the process - installation, about couple of minutes into it.

Can't insert picture for you because serverfault does not allow me to do so. But it basically it: Error message: "Installation failed"

I re-installed SQL 2008 Enterprise on this box and we are not going to go to R2 on older servers that previously had SQL 2005 or SQL 2008 on it.

Looking at Windows log: Activation context generation failed for "C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\SQLServer2008R2\x64\Microsoft.SqlServer.Configuration.SqlServer_ConfigExtension.dll". Dependent Assembly Microsoft.VC80.CRT,processorArchitecture="amd64",publicKeyToken="1fc8b3b9a1e18e3b",type="win32",version="8.0.50727.4027" could not be found. Please use sxstrace.exe for detailed diagnosis.

share|improve this question
    
-1 for unclear question. You need to provide us with more information. How does the installation fail? Where in the process? What error message are you receiving? What steps have you taken so far? Help us help you... –  Adrien Aug 31 '10 at 23:14

1 Answer 1

I fixed it by re-downloading installation file from MSFT. Old installation files worked in June, July, but not in August.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.