Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got cygwin installed on a windows machine & I'm trying to run squid. But when I run /usr/sbin/squid -i it does nothing, no response, no log files, nothing. I've tried searching for solutions but all I've found is one particularly hostile thread on the squid maling list. The doco just says to run with the -i to install as a windows service

share|improve this question

4 Answers 4

up vote 5 down vote accepted

There's no need to run Squid in Cygwin; Guido Serassio maintains binary installers for Windows, invlufi. Try using one of those instead; it has the same exact interface as the Linux versions.

share|improve this answer
    
I must be blind, I can't see the installers on that link. –  barthoda Sep 1 '10 at 2:10

The references to acmeconsulting are no longer current. The commonly referenced page http://squid.acmeconsulting.it/index.html has Squid for Windows v2.7 which is sorely out of date from the current v3.1. On that page is a link for Squid for Windows v3.0. The information there is that due to issues with Bazaar, Squid for Windows is essentially a dead and outdated project. Further, there is no link for v3.x for Windows. Therefore, if you want anything more recent than 6 year old software on Windows, you need to either go for a Cygwin implementation, go virtual with a local VMware instance with *nix, or install on a low-cost cloud-based private server.

My approach: I'm looking into the Cygwin solution now. If that doesn't work, I will progress on to a manually installed VMware instance. If that doesn't work I may try a pre-installed VMWare appliance (DansGuardian?), but only if I can get a personal-use version for free. If that doesn't work, I'll accept that the internet is just slow and deal with it. ;)

Other suggestions for Squid on Windows are welcome, but please, let's start deprecating all of these references to the fine work done at acmeconsulting - it's simply not valid anymore.

HTH

share|improve this answer

From this answer on superuser, I found that I first needed to run /usr/sbin/squid -z and then /usr/sbin/squid. Log files appear at /var/log/squid/ after that.

share|improve this answer

Have a look at this link.
You may be interested at first in the -d option.

You could also try to re-compile squid in cygwin (in setup.exe, install the development tools).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.