Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently purchased a US version of the Alcatel Minitel terminal. I think it's a 1B version. Pictures of it here:

I tried connecting a null modem to the 25 pin port on the back and plugging it into a linux box running agetty but I couldn't get it to show any signs of being connected. I used Google Translate to translate this document into English: http://mirabellug.org/wikini/upload/Documentations_minitel.pdf

As far as I can tell, you take it out of videotex mode by typing Fcnt-T A, then turn off local echo with Fcnt-T E, then set it to 4800 baud with Fcnt-P 4. I presume Fcnt refers to the "CTRL" key on my terminal. But I think I'm doing something wrong, because it doesn't look like it's recognising the keystrokes, because "Fcnt-T A" just prints the letter A to the screen, which is not what you'd expect a function key combo to do.

Has anyone used these minitel terminals as a linux terminal, and if so, please can you share how to configure the minitel to run as a terminal ? Is the 25 pin plug even the correct port to use ? I read something online that indicated you're supposed to use the 5 pin DIN plug instead, is that right ? If so, what's the 25 pin plug for ? If I am supposed to use the DIN plug, does anyone know the pinouts so I can make a cable ?

share|improve this question
1  
That's one crazy but awesome project =D –  Antoine Benkemoun Sep 1 '10 at 8:06
    
Friend and I are struggling with this same project. The problem with the Alcatel terminal is that the serial port is actually 6-pin which is a rather uncommon layout (different from all the French Minitel terminals we've seen). I built a serial cable on the assumption that the pinouts would be the same as on the C64 but this didn't work: See: pinouts.ru/SerialPorts/SerialIOC64_pinout.shtml I just bought a serial tester board to try and determine the correct pinout but am kind of stumbling blindly through this. Looking forward to suggestions from folks with more RS232 experience. –  txtmsg Mar 8 '11 at 7:39
    
txtmsg, I have a unit like yours; see answer below. –  phooky Apr 26 '13 at 20:03
    
Your images have gone missing. –  Michael Hampton Apr 27 '13 at 2:37

4 Answers 4

I recently came across a Minitel 1B made for the US market and got it running. There are a couple of differences from the French version: it runs off 120VAC, it has a 6 pin DIN connector instead of 5 pin, and it uses RS232 line levels instead of 5V TTL. The pinout is below; pin locations assume you're behind the unit facing towards the connector.

  • pin 1 (upper right) - RX
  • pin 3 (bottom) - ground
  • pin 5 (upper left) - TX

Like the unit described above it defaults to 1200 7E1. It also appears to use slightly different "Fnct" commands than the French model; here's what I've sussed out so far:

  • Fnct-B 1 : set baud rate to 1200.
  • Fnct-B 4 : set baud rate to 4800.
  • Fnct-M E : toggle echo.
  • Fnct-M A : 80-column ANSI mode. The text will be noticeably dimmer in this mode (although you can set bold text with ESC [ 1 m, which will be closer to the brightness you see at boot).
  • Fnct-M V : 40-column Videotex mode

I'm talking to it with an FTDI cable passed through a max232. They're fun little terminals!

share|improve this answer
    
It has been ages since I played with one of these, but, if memory serves, you are correct. There ought to be an undocumented 9600 baud setting too, but for the life of me I can 't recall the key-combo. –  Tonny Apr 26 '13 at 21:43

The correct plug to use is the 5 pin DIN, named "Peri-informatique".

Useful pins are (DIN pin numbering can be found on Wikipedia):

  1. RX input
  2. 0V ground
  3. TX output

Electric levels are 5V TTL. Default protocol is 1200 baud, one parity bit, even parity.

Here are some resources, unfortunatelly in french:

share|improve this answer
    
What about the function key commands ? Are they necessary to tell the Minitel to use the serial port or "take it out of videotex mode" ? It still seems like they aren't doing anything so I'm wondering if I have the command keys wrong. –  Pawz Sep 3 '10 at 8:18

I assume you've configured your serial port along those lines: http://www.vanemery.com/Linux/Serial/serial-console.html

I propose you try out different baudrate settings on each side or contact the guy who wrote the tutorial.

share|improve this answer

Nope, You have to use the FCTN button, not CTRL. tested on a Phillips minitel2. press together FTCN and T then release it. then press A. do the same for FCTN+T, E , FCTN+p, 4

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.