Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have running a ubuntu server 10.04.1. I can ping my local network, but I can't get over the router. The DNS entries in resolv.conf are fine. I can post any file you want. Any advice?

Thanks.

netstat output:

$ netstat -rn

Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth1
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth1
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0

ifconfig output:

$ ifconfig -a

eth0      Link encap:Ethernet  Hardware Adresse 00:1a:64:b6:e0:8a  
          inet Adresse:192.168.1.88  Bcast:192.168.1.255  Maske:255.255.255.0
          inet6-Adresse: fe80::21a:64ff:feb6:e08a/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:1750 errors:0 dropped:0 overruns:0 frame:0
          TX packets:489 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:218740 (218.7 KB)  TX bytes:215614 (215.6 KB)
          Interrupt:28 Speicher:92000000-92012800 

eth1      Link encap:Ethernet  Hardware Adresse 00:1a:64:b6:e0:8c  
          inet Adresse:192.168.1.90  Bcast:192.168.1.255  Maske:255.255.255.0
          inet6-Adresse: fe80::21a:64ff:feb6:e08c/64 Gültigkeitsbereich:Verbindung
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metrik:1
          RX packets:2203 errors:0 dropped:0 overruns:0 frame:0
          TX packets:661 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:241347 (241.3 KB)  TX bytes:161640 (161.6 KB)
          Interrupt:40 Speicher:94000000-94012800 

lo        Link encap:Lokale Schleife  
          inet Adresse:127.0.0.1  Maske:255.0.0.0
          inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
          UP LOOPBACK RUNNING  MTU:16436  Metrik:1
          RX packets:2165 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2165 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:0 
          RX bytes:977279 (977.2 KB)  TX bytes:977279 (977.2 KB)

usb0      Link encap:Ethernet  Hardware Adresse 02:1a:64:b6:e0:91  
          BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

vboxnet0  Link encap:Ethernet  Hardware Adresse 0a:00:27:00:00:00  
          BROADCAST MULTICAST  MTU:1500  Metrik:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
share|improve this question
    
Are you trying to get an out-going connection to the internet from your server; or trying to get an in-coming connection from the internet to your server? –  sybreon Sep 1 '10 at 8:13
    
i want to make a simple apt-get update :) –  Tronic Sep 1 '10 at 8:17

4 Answers 4

You've got 2 default routes, and it appears from your comments that only one interface is bridged with a real network, I'd suggesting getting rid of one of the routes:

sudo /sbin/route del default eth0

share|improve this answer
    
In fact, you are using the same IP address on two interfaces. Check your interface configuration. The same IP address on two interfaces will never work. –  wolfgangsz Sep 1 '10 at 11:43

Please post netstat -rn and ifconfig -a.

share|improve this answer
    
i edited my original post, see above! –  Tronic Sep 1 '10 at 8:24
    
I see you're running Virtualbox. Do you want to 'apt-get' from a VM or from this physical host? –  weeheavy Sep 1 '10 at 8:37
    
the virtualbox is bridged with the eth1 port. i use the eth1 (physical) for apt-get! –  Tronic Sep 1 '10 at 8:54
  1. Make sure that you can ping your router to ensure that there is a valid connection between your server and router.
  2. Check the settings on your router to ensure that it is not filtering your server traffic and that it allows connections on port 80 from your server.
  3. Ping an internet server like serverfault.com to see if you can gain access to the internet.
  4. Check your sources.list setting for apt-get to see if you have configured it correctly.
  5. If there is a transparent proxy running on your network, check to see that it is not filtering your server traffic.
share|improve this answer
    
ping router: works ping serverfault: doesn't work, the ping stucks after PING serverfault.com (69.59.196.211) 56(84) bytes of data. so no messages like "no route to host....". sources.list are standard, haven't change anything... no proxy or firewall, route is ocnfigured to NAT with port forwarding to another server (just web) –  Tronic Sep 1 '10 at 9:02

If you want two IP addresses on the same subnet you should add them on the same interface. you would have:

eth0 eth0:0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.