Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a VMWare virtual machine running Windows Server 2008 R2. I've installed the latest updates and the Windows SDK, and I'm in the process of installing SQL Server 2008 R2. I'm not getting very far with the installation, though. When the installer tries to show me a list of features available, the installer crashes, and I get this error message:

SQL Server setup failure

I tried enabling assembly binding logging and going through the logs to find more information on the error, but no error seemed to match the last bit of the type name shown in the image.

share|improve this question
    
Almost looks like you've got the wrong language distro. (Should post to thedailywtf.com and failblog.org) –  squillman Sep 1 '10 at 13:20
    
I agree. What language is the OS, and what language is the SQL installer? –  mrdenny Sep 1 '10 at 18:28
    
See my answer below, I used a corrupted media set at first, and after figuring that out, forgot to uninstall the (apparently corrupted) setup support files. –  Rytmis Sep 2 '10 at 6:23

1 Answer 1

up vote 0 down vote accepted

OK, figured it out. I neglected to mention that I tried the setup before with different media, and a md5 check showed that the media was in fact corrupted. As it happens, the installer left bits of the corrupted media on the target server, under the name "Setup Support Components". Removing those via Control Panel fixed the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.