Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I upgraded my Ubuntu 8.04 To Ubuntu 10.04. Unfortunately, the upgrade process also updated the Postgres 8.3 install to an Postgres 8.4 install. My feeling is that although database engine binaries have been updated, the database itself was not migrated, hence it can not be loaded by the 8.4. Since the 8.3 data format is not compatible with 8.4 format, altering postgresql.conf is not enough, nor can I use pg_dump with my 8.4 install.

I need a way to upgrade my previous base from 8.3 to 8.4, with no access to a 8.3 engine, only a 8.4.

Any clue ?

Thanks !

share|improve this question

2 Answers 2

up vote 4 down vote accepted

Read /usr/share/doc/postgresql-8.4/README.Debian.gz and man pg_upgradecluster.

share|improve this answer
    
Thank you Jan ! Actually I didn't check enough the "cluster" topic. I didn't know that adefault cluster was created (misunderstanding of clustering, which I though I didn't use [no replication, no load balancing]). –  SCO Sep 2 '10 at 8:49

I've just solved this by compiling a 8.3 from the source : ./configure --enable-integer-datetimes --without-readline then make and make install

After that, started 8.3 with : /usr/local/pgsql/bin/postgres -D /var/lib/postgresql/8.3/main -c config_file=/etc/postgresql/8.3/main/postgresql.conf and then dumped my 8.3 base : sudo /usr/bin/pg_dumpall -o -U postgres > /local_pc/tmp/backup.txt

Restarted 8.4, and pg_restore'd it, worked like a charm.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.