Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm running a PHP site on my local MacBook Pro, which requires Soap. I went to /usr/local/src/php-5.2.11/ext/soap, and ran "make install". It completed successfully. I went to the /usr/local/src/php-5.2.11/ folder, and ran ./configure with many options including --enable_soap.

When I go to http://localhost/phpinfo, it does not list --enable_soap in the Configure Command.

If I add "extension=soap.so" to my /etc/php.ini, then I get this warning when I run php:

  PHP Warning:  PHP Startup: Unable to load dynamic library './soap.so' - (null) in Unknown on line 0

I tried restarting apache, which didn't make a difference.

What am I doing wrong? Help!

share|improve this question
add comment

1 Answer

You don't say anything about installing fink or macports or installing a separate apache/php installation so I guess you tried that with the default install on OS X. This isn't going to work, as Apple delivers a customized version of this stuff and you can't add modules to it.

What you have to do is to deactivate the default apache in System Preferences->Sharing->Web Sharing and then install your own stack with either fink or MacPorts (with MacPorts you can just add the package php5-soap). Other options might be MAMP or installing directly from source, which is likely quite involved.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.