Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Here is my problem: after default installation of apache2 for Ubuntu it's started to retrieve old pages for Trac, for example, I made a small changes (simply edit page) in trac-wiki section, push "Submit" button, and after the page updated I saw a page with new changes, but when I click on "Edit" button again on the same page, it gave me the edit page without the last changes (cache gave me back the old page - and I have to press F5 to update the page)...

PS: when I configured HTTPS on my server, the problem for HTTPS content disappeared!

Here is what I'm using:

  1. System: Linux hostname 2.6.32-24-generic #39-Ubuntu SMP Wed Jul 28 05:14:15 UTC 2010 x86_64 GNU/Linux
  2. Trac 0.12
  3. Python 2.6.5
  4. Apache 2:

$ apache2 -V
Server version: Apache/2.2.14 (Ubuntu)
Server built:   Apr 13 2010 20:22:19
Server's Module Magic Number: 20051115:23
Server loaded:  APR 1.3.8, APR-Util 1.3.9
Compiled using: APR 1.3.8, APR-Util 1.3.9
Architecture:   64-bit
Server MPM:     Worker
  threaded:     yes (fixed thread count)
    forked:     yes (variable process count)
Server compiled with....
 -D APACHE_MPM_DIR="server/mpm/worker"
 -D APR_HAS_SENDFILE
 -D APR_HAS_MMAP
 -D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
 -D APR_USE_SYSVSEM_SERIALIZE
 -D APR_USE_PTHREAD_SERIALIZE
 -D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
 -D APR_HAS_OTHER_CHILD
 -D AP_HAVE_RELIABLE_PIPED_LOGS
 -D DYNAMIC_MODULE_LIMIT=128
 -D HTTPD_ROOT=""
 -D SUEXEC_BIN="/usr/lib/apache2/suexec"
 -D DEFAULT_PIDLOG="/var/run/apache2.pid"
 -D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
 -D DEFAULT_ERRORLOG="logs/error_log"
 -D AP_TYPES_CONFIG_FILE="/etc/apache2/mime.types"
 -D SERVER_CONFIG_FILE="/etc/apache2/apache2.conf"

Thanks for advice!

PSS: If you need some more outputs of some configures, just comment me, and I append them to my question post!

share|improve this question
    
Try ctrl+f5 in your browser. Might be the browser that is caching the page and not the webserver. –  Espennilsen Sep 2 '10 at 7:53
    
@Espennilsen: I have 100% sure, that it's not the browser cache. –  mosg Sep 2 '10 at 8:01
    
If it's the browser caching, that might be because the server tells it that caching is safe... –  JanC Sep 2 '10 at 10:29
    
@Jan Claeys Sorry, but I have not got you post... In my case, as I mentioned this is NOT the browser cash... Thanks. –  mosg Sep 2 '10 at 11:57
    
Does this problem appear on other browsers, on other computers? Check that first before delving into Apache configuration. –  Andrew M. Sep 2 '10 at 12:29

1 Answer 1

up vote 0 down vote accepted

Solution: the problem was in corporate proxy. If I'm using other Internet Providers, the problem disappeared!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.