Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just upgraded a site from an old win 2000 server to a new win 2008 64bit server.

This site accepts image uploads from a desktop application via a POST of XML data where the image is base64 encoded into one of the xml elements. The page that receives the POST data is Classic ASP.

Since moving to the new server, only small images can be uploaded successfully.

Max allowed content length is set to 30000000 bytes. So I should be able to POST just under 30MB.

I can't POST xml of an encoded image of anything around 1mb and higher.

The error occurs when loading the XML on the server-side (this happens using a VB dll).

There was never a problem with large file sizes on the old win 2000 server and this code has not changed.

The error I get is:

Unspecified error
Error Code : -2147467259
File Position : 262165
Line : 3541
Line Position : 56
Source Text : cvr92x0lnpkUw/0gfuvKqXTYYptY8+3q74Jhls7eSfHnfunql4J026mu
URL :

So that looks like the POST is getting cut off somewhere in the middle of the XML.

Any Ideas on what to set apart from the Max allowed content length in IIS - I'm setting that for the site in IIS under Request Filtering.

share|improve this question

3 Answers 3

Is the POST error occurring instantly or after a specified amount of time?, I think you need to add "maxRequestLength", try adding this to "system.web" in your web.config -

<system.web><httpRuntime executionTimeout="999999" maxRequestLength="2097151"
share|improve this answer
    
I tried this but it didn't make any difference. I believe this setting only applies to ASP.NET - the page that I'm posting to is Classic ASP. –  Nils Sep 13 '10 at 13:38

IIS7 has a default upload cap of 28.61MB. You have to open this file:

C:\Windows\System32\inetsrv\config\applicationHost.config

In the <requestFiltering> section you add the following:

<requestLimits maxAllowedContentLength=”[length in bytes]” />

For 100MB you could set it to 104857600 for example.

share|improve this answer
    
I already have this set to 30000000 - my POSTS are less than 5MB –  Nils Sep 13 '10 at 13:21
    
I think it's a number of factors including maxAllowedContentLength (as suggested by you) and maxRequestLength (suggested by user20849). Your suggestion helped me solve my problem - thank you very much! –  Mayo Apr 29 '11 at 13:13

Possibly an issue with your IIS configuration still not changed to allow large payloads ;) Check all relevant settings in web.config.

share|improve this answer
    
What would I have to check apart from Max allowed content length? –  Nils Sep 2 '10 at 13:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.