Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I was given a tutorial on setting up apache2 and php to work with a java CMS called liferay. the problem is that the instructions were written for linux. Can someone help me change these to work with windows environment?

ssh into the server. 

cd /var/www/ 

sudo mkdir directory name 

sudo nano (or vim if you prefer) index.php 

Enter this into the text editor. 

         echo "Hello World!"; 

cd /etc/apache2/sites-enabled/ 

sudo nano (or vim if that's your preference) 000-default 

Make sure the first item on the page looks like this... 

NameVirtualHost *:80 

Make sure the <VirtualHost> directive looks like this... 

<VirtualHost *:80> 

Save and exit the file. 

sudo nano liferay.conf 

Make sure the <VirtualHosts> directive looks like this... 

Add an alias inside the <VirtualHost> tag. 

Alias /apps "/var/www/apps" 

Add a <Directory> directive inside the <VirtualHost> tag. It should look like this... 

<Directory "/apps/">

 Options FollowSymLinks 

      AllowOverride None 
      Order allow,deny 
      Allow from all 
      ProxyPass [http://localhost:80/apps/] 

Save and exit the file. 

Restart the server 

/etc/init.d/apache2 restart 

things like the directory site-enabled don't exist, etc. so am having a hard time here.

Thanks a lot!


share|improve this question
Just use whatever file(s) your Apache install uses to configure virtual hosts (this might differ depending on where you got your installer from). – JanC Sep 2 '10 at 11:01

The file you are looking for is httpd.conf, probably in "conf" directory of the apache installation. You can also check httpd-vhost.conf into "conf/extra" directory.

share|improve this answer
thanks for replying. I thought that too but when I add the line <VirtualHost *:80> and try to restart apache I get an error – iamjonesy Sep 2 '10 at 11:12

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.