Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows Exchange 07 and all my users are using Outlook (2k3, 2k7, 2k10). Every time I need to reboot the server for maintenance, their Outlook lost the connection, but when it's back online, it's asking for credentials.

The problem is, the default login is myDomainServer\login instead of myDomain\login, I don't understand why it's using my server name by default instead of the domain name.

I'm sure it's something easy and stupid but I just can't find it :(

Thanks for your help !

share|improve this question

3 Answers 3

If you're using RPC over HTTP, look at:

http://support.microsoft.com/kb/820281

and

http://www.eggheadcafe.com/software/aspnet/33885167/outlook-repeatedly-asks-for-login-credentials.aspx

Towards the bottom of the eggheadcafe article has what looks like a likely possibliity

share|improve this answer
    
Yes i'm using Outlook Anywhere with NTLM authentication, but I check the regedit : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\lmcompatibilitylevel it's already on 3. –  Bastien974 Sep 3 '10 at 15:35

Have you tried this: http://support.microsoft.com/kb/956531

Another thread suggested verifying your internal DNS records

Also, 1. Make Sure Outlook is closed 2. Then go to start/settings/Control Panel

  1. Double Click on Mail/Then E-mail accounts
  2. On the email tab highlight your username(Exp. example@abc.com) and hit Change
  3. Then Click on More Settings/Connection/Exchange Proxy Settings
  4. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the sstd:webmail.covad.com box will go grey.
  5. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
  6. Open Outlook and Put in Domain(Your username) and password.
share|improve this answer
    
I have this issue on a majority of my outlook on the domain when they lost the connexion with exchange and try to reconnect. The first time they execute Outlook, they never have to put in any credential since they logged on the domain. Isn't it rather a configuration on the server side ? –  Bastien974 Sep 2 '10 at 16:55
    
Try it; if it doesn't work we'll continue looking. –  gWaldo Sep 3 '10 at 0:27
    
You're telling to do that on every single computer ? Even if it works, there must be something on the server side that can fix that ! Thx for your help gWaldo. –  Bastien974 Sep 3 '10 at 14:06
    
I'm suggesting that you try it on a few computers to see if it works. If it does, it may be scriptable. Yes, it's possible that your server is misconfigured, but I don't know off-hand how, and I don't have an E2k7 box to check; I'm running E2k3. –  gWaldo Sep 3 '10 at 14:50

This sounds like to me that credentials have been saved in Credential Manager (assuming Windows Vista, 7 or 8) and this is why you're getting the bad username field that has this random server name (this wouldn't be coming from Server Side). Have you checked to see if there is a couple of bad credentials saved on these workstations that have the issue?

Outlook by default will fail to Outlook Anywhere HTTP if it loses connection to Exchange. To avoid the prompting one could:

  1. Advise users to log off during maintenance task on Exchange. Or at least close down and reopen Outlook. I tend to go with this option.
  2. You could as an admin just disable Outlook Anywhere (this would be kind of silly as Exchange 2013 and beyond is all RPC over HTTP.
  3. Stop the Exchange Server Client Access RPC Service before you reboot the server. This will just fail all Outlook clients instead of having them try the Outlook Anywhere RPC. I personally don't like this as I want to give the ability of Outlook Anywhere to try in the event of some type of RPC Proxy issue!
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.