Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a windows 7 pc in a windows 2003 server environment. every now and then (about twice a day), the gateway setting is changed to 0.0.0.0 and 192.168.1.1.

Now, the 192.168.1.1 setting is correct, but the 0.0.0.0 is not correct. In fact, it blocks all network traffic.

  • There are no other computers showing this behaviour.
  • After reinstallation of Windows 7, the problem occurs again.
  • windows calls the network adapter 'Broadcom Netlink gigabit ethernet'

How do I stop this particular computer from getting an extra gateway address?

share|improve this question

8 Answers 8

I would indeed look for a rogue DHCP server dishing out incorrect information. DHCP should not ever issue 0.0.0.0 as a default gateway, but it is possible to implement this. It might also be a problem with one of the other virtual interfaces. Windows 7 adds several of new virtual interfaces for features like the 4to6 bridge & such.

When this problem occurs... can you snag a copy of your routing table & post back here. Also pay close attention to the metric.

share|improve this answer

It sounds like something is corrupt in your TCP/IP stack on the client. Here's my default answer for when that happens. Reset winsock. Reset TCP/IP. Reboot computer. Here's how you do the first 2 things:

netsh winsock reset c:\winsock.log
netsh int ip reset c:\ipreset.log

share|improve this answer

The 192.168.1.1 sounds a lot like ICS (Internet Connection Sharing), you might check to ensure that it is not possibly enabled via the NIC's "advanced" properties.

share|improve this answer
    
sorry, but what has this IP address got to do with ICS? –  Cold T Feb 23 '12 at 17:26
    
That is the default gateway as part of the 192.168.1.0 IP plan that ICS assigns. Enabling ICS will assign 192.168.1.1 onto the NIC that it is enabled on. –  user48838 Feb 23 '12 at 17:32

I have seen the same issue. I checked out DHCP server logs and for some reason the DHCP server (Windows Server 2008) is sending two responses back to our windows 7 clients within 3 seconds of each other. On the client I have the real IP address with the correct gateway, and also a second gateway of 0.0.0.0. The client then can only find IP address within the local subnet. Also, the windows 7 clients show both a "Work" and "Public" network type. Disabling the network interface and running a fix (in Windows 7) seems to fix the issue and the seconds "Public" network disappears. Not sure what is causing this initially. Anybody find anything else out?

share|improve this answer
    
This does not answer the question. It is more of a comment –  James A Mohler Dec 6 '12 at 1:05

I found a way of solving this problem. Open a command prompt with administrator permissions on the client computer and run the following commands:

route print

Note: This will show you the routing table where you will see the wrong gateway. To remove it do the following:

route delete 0.0.0.0
ipconfig /renew

And the gateways will be ok. For me, this is working.

share|improve this answer

New member. First forum reply. Lots of rules to abide by.

I had this exact problem, although in my home environment. I realize this is not a forum for home users but this thread was found during a search for the identical symptom (i.e. 0.0.0.0 along with 192.168.1.1 as the gateway), although in my case the symptom always occurred at Windows boot time when networking was just getting started.

Until today, my own solution was to do a DISABLE and then and ENABLE for the ethernet LAN adapter in Network Connections. That always worked and the extraneous 0.0.0.0 network disappeared, and 100% normal Internet access resulted, but I had to do it every time I booted the laptop. Quite annoying.

So, although I'm not a systems administrator but simply a home user, I joined this forum today to be able to thank Jason Berg for his super-basic and super-simple "pull the plug, wait 30-seconds, plug it back in. Did the problem go away? Great. Case closed." suggestion posted earlier, which actually DID WORK for me to solve my own problem!!!

Reset winsock. Reset TCP/IP. Reboot computer.

netsh winsock reset c:\winsock.log
netsh int ip reset c:\ipreset.log
reboot

Sure enough, when my system was rebooted the symptom had completely disappeared. I only saw the one valid ethernet LAN network path to my router, and I immediately had Internet access. Since this had been failing for a year (yes, that's how long I've been booting followed by DISABLE/ENABLE) I couldn't believe that it could be fixed simply by deleting and recreating the TCP/IP stack.

So I retried the reboot three times. And each one was again successful... only the 192.168.1.1 gateway, and instant Internet access working perfectly.

Therefore, again my thanks go out to Jason Berg for his suggestion.

Worked for me.

share|improve this answer
    
Hi @Dsperber, and welcome to ServerFault! It's very nice of you to want to thank Jason for his help. However, this isn't really a forum. Writing a second answer that doesn't contain any new information that could help the poster (or anyone else searching the site) isn't the best way to do it. Instead, you should just upvote the answer from Jason (by clicking on the up arrow to the top left of the post). If you hang around a little here, I'm sure you'll find some question that you can answer - this will give you enough rep that you can post a comment on Jason's answer to thank him. –  Jenny D 21 secs ago
    
Please don't add "thank you" as an answer. Once you have sufficient reputation, you will be able to vote up questions and answers that you found helpful. –  Jenny D 6 secs ago

The Win2k3 server is running the DHCP service? Are you sure there aren't any other DHCP servers on the network, eg the router?

What do you mean by 'double gateway'? The TCP/IP properties of a NIC only support having a single gateway, you can't have 'double gateway'.

A gateway of 0.0.0.0 can often mean that negotiation of a DHCP lease has failed, and no gateway has been set. This will be obvious because when this happens you also don't get assigned an IP address, and your IP will be self-assigned to an address in the 169.254.xx.xx range.

If this is happening, a workaround is to go into the NIC's tcp/ip properties, and under the 'Alternate Configuration' tab, configure an IP/subnet mask and gateway address that matches the correct values for your current network. That way if DHCP negotiation fails it will fall back to this configuration and things will keep working. Note this doesn't treat the underlying cause of the problem.

share|improve this answer
    
You can have as many default gateways as you want. There is no limit. –  TheCompWiz Sep 3 '10 at 14:47
    
Please re-read my post. You can only have a single default gateway per NIC. It is possible to have multiple gateways with multiple NICs, but I don't see how you could have more than one default gateway per NIC, as this goes against the very definition of 'default'! –  imoatama Sep 6 '10 at 4:05
2  
imoatama - you can have several default gateways!! you can go to TCP/IP settings, advanced, in "IP Settings" there is Add default gateway. –  miro23 Feb 16 '11 at 16:47
    
-1. Obviously never seen advanced configuration options for tcp. –  TomTom Feb 23 '12 at 13:49

This is most certainly caused by an IP-conflict on the network. Check your DHCP server and remove any BAD_ADDRESS, then restart the client.

share|improve this answer
1  
-1 Sorry, but no. If his local IP was 0s or auto-ip then maybe yes; but the DG getting set to 0s isn't an IP conflict. –  Chris S Feb 23 '12 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.