Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Edit:
Thank you all for your answers. They were quite helpful (and I would vote them up if I had enough reputation to do so), but unfortunately not the answer so far. For some reason, my printer (HP Color Laserjet CM1312fni) does not show up even after trying everything named in the answers.
However, I found that I can manually map printers to "ports" by going to: Printers > Properties > Ports (my translations may be wrong, as I'm working with a German version). I get a list with all classic ports like LPT1, COM1, etc. as well as a couple of TS00x ports with x IN {1..5} pointing to one of the printers I've installed locally. Through some trial and error I've now managed to set up what I wanted. However.... the question remains unanswered, since an automatic mapping is supposed to be working.

Cheers,
Robin

--

Greetings!

From my WinXP Pro ("site A"), I'm connecting to a Win Server 2008 ("site B") using mstsc. In my LAN on "site A" I have a network printer, and I need to be able to print on this from within my mstsc session on "site B".

Background
My customer wants to set up a server ("site B", correct) and have several external branches work on that, using mstsc. Ie. all applications, settings, database, etc. are all on the server; the only application running in the branches is the terminal client.
Of course, when people want to print something, they want it to be printed on their local printer, not are "site B".

What I've tried already
Obviously, I checked the "share printers" option in the mstsc connection options > local resources.
Also, I share the printers in the local printer settings.
When nothing worked, I also shared a local PDF "printer" on my PC and shared it.

None of my local printers are visible in my terminal session... not in the network area, not in Printers. I'm running out of ideas...

Any help would be greatly appreciated! Thank you, and
best regards Robin

share|improve this question

4 Answers 4

If you're using the MSTSC (microsoft terminal services client) to remote into a remote machine, it should attempt to share the printer through the RDP protocol, and automatically create it on the other side.

This process can fail when the printer's driver isn't installed, and the "Terminal Services Easy Print" driver is not installed. The easiest way is simply to install the same driver on the server that is used on the workstation. (The name of the driver is VERY IMPORTANT... otherwise it considers it a different printer. Things like "HP Laserjet 4000" and "HP Laserjet 4000 (ms)" are treated as 2 different printer models & won't map the printer driver)

I'm not 100% sure, but I believe the 2008 server has the "Terminal Services Easy Print" driver turned off by default. Simply turn it on and in theory all printers that don't have the driver installed, will default to the easyprint driver. In reality, I've had lots of troubles trying to make it work in XP 100% correctly. There are several known problems with it, and I would suggest you look at installing the "manufacturer's driver" rather than relying on the easy print driver.

At a minimum for XP... make sure you install XP SP3 & Dot-net 3.5 to make "Terminal Services Easy Print" mostly work.

share|improve this answer
    
I just checked and the TS Easy Print feature is enabled by default and is tried first before trying to find a matching driver on the server. –  joeqwerty Sep 3 '10 at 23:22

You need to install the printer drives onto the server. To do this, go to the Printers control panel, then go to File->Server Properties->Drivers. At that point, add each driver that you need for the clients.

share|improve this answer

A few things:

  1. Sharing the printers has nothing to do with it so stop doing that and undo what you've done so far.

  2. On the client make sure that you've got printer redirection enabled in the RDP client.

  3. On the server make sure you've got printer redirection enabled. This can be enabled via GPO or it can be enabled directly on the server.

  4. Make sure you have printer redirection enabled on the user account.

  5. You can install the corresponding printer drivers on the server, or you can enable the Terminal Services Easy Print feature if the clients meet the requirements (I believe it's used first so you may not have to actually enable it although it can be enabled\disabled via GPO), or you can create a custom ntprint.inf file and configure the server to use that and manually create printer driver mappings in the inf file.

share|improve this answer

Sometimes, even when you have everything set up correctly, and things "should work", they don't. I just ran into this with a Win2k8 server and Win7 client that we were trying to setup local printing for. I figured I'd share my fix...

I had an HP printer connected via USB to the client, but print jobs initiated through the RDP connection on the server would fail.

What I ended up doing was sharing the printer from the client (\client\printerName), then mapping the share on the server through the add printers wizard.

It looks and feels hackish, but it worked and works.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.