Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

mod_rewrite is not working for my wordpress install on fedora. The module is loading, and AllowOveride is set to All in httpd.conf.

Ive restarted apache, and restarted the machine also incase that worked. Im totally lost.

here is my .htaccess file

AddType x-mapp-php5 .php
Allowoverride FileInfo

# to protect thisfile
<Files ~ "^\.htaccess">
Order allow,deny
Deny from all
</Files>

# to protect wp-config.php
<Files wp-config.php>
order allow,deny
deny from all
</Files>

# BEGIN WordPress
<IfModule mod_rewrite.so>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Thanks

share|improve this question
1  
have you checked the logs? –  Marco Ramos Sep 3 '10 at 18:44
    
apache logs? it just says file not found. –  madphp Sep 3 '10 at 18:56
    
RewriteLog RewriteLogLevel are your friends. –  Mark Wagner Sep 3 '10 at 20:10

1 Answer 1

up vote 0 down vote accepted

File not found? Which file, wp-config.php? IS the wp-config.php in the same directory as the .htaccess?

share|improve this answer
    
no, all wordpress permlinks that im trying to access come back file not found. wp-config is there, and the entry in the .htaccess is just to hide it from robots. –  madphp Sep 3 '10 at 19:59
    
I removed AddType x-mapp-php5 .php Allowoverride FileInfo as those were causing a 500 error on my server. Other than that I copied your script aside from the BEGIN wordpress section, as I already had that, pasted it into a wordpress install on one of my machines, and tried to access wp-config. Forbidden You don't have permission to access /techtalk/wp-config.php on this server. So it works for me, other than the first two lines. –  Kyle Buser Sep 3 '10 at 20:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.