Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Related to my post here on SO:

http://stackoverflow.com/questions/3638584/smtpclient-sending-bad-messageids/3638682#3638682

It was brought to my attention that our exchange settings may be incorrect.


Overview

The messages sent by the emailer (SMTP) have incorrect MessageID headers.

Message-ID: <98bcd4e6-be30-4b22-8026-6047c8231b1f>

Where they should look something like this:

Message-ID: <F09A215A213060419E28A88E85FDC8FD0CCEB91C23@EXCHANGE-SERVER.MYDOMAIN.mycompany.com>


I'm assuming one of our settings are incorrect, anyone know what needs to change?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Pierre 303 is incorrect about who is responsible for setting the Message-ID header. SMTP requires that there is one, it does not specify who creates it. Mailers are supposed to provide one if an incoming message lacks one, which does not stop programs that send mail from setting their own.

As it happens, Exchange 2007 SP1 does have an issue related to this (link). If you happen to be running before this version this might be why the Message-ID is not being completely filled out per conventional usage.

share|improve this answer
    
Thank you for clearing things up. –  Aren B Sep 3 '10 at 20:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.