Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install Ubuntu 10.04 LTS Server on Server 2008 R2 Hyper-V. I have setup a hard drive that is 400GB. Yet every time I try to install it only recognizes it as a 136gb drive.

I have tried the following:

SCSI HD vs IDE HD

Fixed vs Dynamic disk

Diff SCSI and IDE channels

Any ideas?

Thanks!

share|improve this question
    
136GB (127GiB) is the pre-ATA/100 interface limit if that helps anyone. –  Rob Olmos Sep 4 '10 at 1:50

2 Answers 2

up vote 2 down vote accepted

I had the same problem as this and found the solution here: http://fawzi.wordpress.com/2010/05/03/ubuntu-server-10-4-in-hyper-v/

Although this article is about the synthetic NIC and how to use that instead of the legacy driver it also worked for the larger drive. I created a small VHD and added it to the IDE Controller as the root partition to boot from as /dev/hda1 and then created a big VHD and added it to the SCSI Controller. When the drive was mounted it showed the full space available in fdisk.

If the hv_ modules are not loaded then I could not see the drive as a device at all.

NOTE: If you follow the above website instructions to use Synthetic NIC then you'll also need this article: http://ubuntuforums.org/showthread.php?p=9876653

As the synthetic NIC didn't work for me until I did the above.

share|improve this answer

I haven't used Hyper-V but try something more related to the virtual BIOS or controller settings like 48-bit LBA.

share|improve this answer
    
All the BIOS settings seem to work fine. Also with CentOS the hard drive size shows up fine. So it is only Ubuntu. Any ideas? –  Physikal Sep 9 '10 at 23:27
    
It's also Debian –  Christian Oct 11 '10 at 8:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.