Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am facing a strange problem. The FTP on my Plesk VPS is not working. Whenever I try to connect, FileZilla FTP client says:

Status: Resolving address of xxxxxxxxxxxxx.com
Status: Connecting to xxx.xxx.xxx.xxx:21...
Status: Connection established, waiting for welcome message...
Error: Could not connect to server

So, it's not even going to the step of asking username/password. So, it's something else.


The SFTP on port 22 is working fine. Also, I can successfully do shell access and run commands.

But, I NEED FTP access too on port 21. I have searched everywhere but can not find any setting to enable it. This is the Plesk version info:

Parallels Plesk Panel version 9.5.2
Operating system Linux 2.6.26.8-57.fc8
CPU GenuineIntel, Intel(R) Pentium(R) 4 CPU 3.00GHz

Any help is appreciated.

[EDIT]:

The firewall is not blocking it. I have checked it on server and there are absolutely no blocking rule. Firewall states:

All incoming/outgoing connections are accepted on FTP

And on client-side (my PC), I can connect to other FTP servers so this is not an issue in my PC's firewall. Moreover, I can not even connect to the FTP from online FTP clients like net2ftp.

share|improve this question

closed as off-topic by Falcon Momot, MadHatter, EEAA, Ward, Jenny D Oct 21 '13 at 10:13

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is a site dedicated to professionals; novice questions are off-topic. Please see the Help Center for more information on topicality. The best advice we can give you is to hire a professional to help you out." – Falcon Momot, MadHatter, EEAA, Ward, Jenny D
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Sounds like the FTP server isn't started. But since I (willingly) know nothing of Plesk, that's all I can help with. –  Ignacio Vazquez-Abrams Sep 4 '10 at 16:49
    
What version of linux are you using? Does the command "service --status-all" do anything for you? –  Safado Oct 10 '11 at 15:04
1  
If you have functional SFTP, why do you "need" regular FTP? It's an inferior protocol in every single aspect, both securitywise and in terms of efficiency. –  Shadur Jun 27 '12 at 8:11
1  
If you have working SCP/SFTP - is it blocked for security purposes? FTP is garbage security. Only need anymore is for anonymous, maybe, possibly... Meh, no not even for that. –  Fiasco Labs Aug 19 '13 at 6:18
add comment

3 Answers

Maybe your VPS provider doesn't want you to use FTP (it's not very secure after all...)? Did you check their documentation and/or ask their support people about this?

share|improve this answer
    
I have got the root access and everything. I can enable that myself. Just want to know how to do that. –  shamittomar Sep 4 '10 at 20:05
add comment

I would check if FTP server is running at all. It could be also blocking rule on firewall
--
Regards,
Robert

share|improve this answer
    
Firewall is not an issue. See my updated question. And how do I check if FTP server is running or not? What command should I issue on shell to check this. Please elaborate. –  shamittomar Sep 6 '10 at 3:22
2  
You can check the output of netstat -tlp run as root. –  JanC Sep 6 '10 at 17:06
    
alternately, ps axuf and see if there's any running process with the phrase ftpd in it. Alternately, something named inetd, which would be your cue to check /etc/inetd.conf. –  Shadur Jun 27 '12 at 8:10
add comment

You can try restarting PLESK, which in CentOS for me is

/etc/init.d/psa restart

Then, try restarting the PLESK FTP service specifically

/etc/init.d/xinetd restart

And for laughs, Apache as well

/etc/init.d/httpd restart

I'd also update PLESK.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.